FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
868 views 7 comments
by anonymous

Hi
I recently received my TRB500, that im using as a backupconnection.

Everything works when NAT is enabled without my edgerouter.

But when i change the mobile settings to bridge mode /passthrough with and without DHCP the connection breaks. 
I have:
-Checked the mac address on my edgerouters eth0 port several times.
-Tried without any mac adress
-Tried with and without dhcp enabled in the mobile settings

-Tried with and without DHCP enabled on network LAN settings.

-Checked several times that  DHCP is enabled on eth0 on edgerouter

-Tried without the automatic failover feature on the edgerouter

I tried upgrading to newest firmware: FW VERSION bTRB5_R_00.07.04.2

Tried resetting several times, restarting both the edgerouter and the teltonik.
If i use an old huawei modem i have around it works to the edgerouter when enabling bridge mode.

Could it be a firmware issue?

by anonymous
I forgot to mention that i also followed the guides for passthrough and bridge mode.
In passthrough mode it bricks my edgerouter (i think it tries to act as a dhcp).

Is there some issues on the TRB500 firmware?
Please how can i fix this?
by anonymous
It would be nice to know if bridge mode is actually working for anybody on current firmware as this is a feature which is supposed to be working according to product description and consumers are paying for.

From my experience bridge mode stopped working in RUT240 after some specific legacy fw version.

2 Answers

0 votes
by anonymous
Hello,

  

Perhaps you could try using passthrough/bridge modes on any other device (e.g. your PC) and check if it gets an IP address assigned?

Also, make sure that only the EdgeRouter is connected to the TRB500 when enabling passthrough/bridge mode. Generally, Bridge mode might be a better choice in this case if you do not need any of the other TRB500 features.

Let me know how it goes.

  

Best regards,
DaumantasG
by anonymous
Hi DaumantasG

Thank you for the answer. I already tried this, but the edgerouter is not able to obtain an ip. Can i check some logs on the teltonika?
Compared to the HUAWEI 5G CPE Pro 2 the connection feels so slow and unresponsive. The signal looks good, its sitting at the same location as the Huawei. I checked if it was a DNS issue but no. Shouldn't it be better performing?

I also need to know how i can obtain logs, when i have to reset to factory before i can log onto the trb500 again after setting it in bridgemode?
by anonymous

Hello,

  

Apologies for the delayed response.

To reach the WebUI of the TRB500 after it has been set to operate in bridge mode, you will need to set a static IP in the LAN range of the TRB500 (192.168.2.0/24 by default with 192.168.2.1 being the gateway).

Once you reach the interface, I will ask you to navigate to System → Administration → Troubleshoot and generate a troubleshoot file. this file can be attached to the original post and will only be visible to Teltonika moderators. 

  

Best regards,
DaumantasG

0 votes
by anonymous

Hello,
Yes, I can also confirm you that there is issue with Passthrough in firmware that is not working correctly with all devices, for quite some time.
I use Teltonika RUT240 set in Passthrough - it is correctly assigning edge-router (behind connected) public IP address, but overall Teltonika is generally blocking traffic and routing to Internet, itself.

I tested Passthrough using RutOS versions from _R_00.07.03-07.04 with Cisco 800 series routers - this works fine.
On the other hand, using it with combination with Juniper SRX 2xx series or other Huawei's like AR651 - Passthrough is failing, not working, blocking trafic but  it's assigning IP address to edge routers. Routing to Internet is not possible. Not sure for Fortigate's didn't test it out, yet. [EDIT 2023-05-16 today I tested out with Fortigate 40F FortiOS 6.4.11 works fine OK with Teltonika/Passthrough]

Last firmware version that is correctly supporting and compatible with Passthrough (working good) with RUT240 with many Vendors connected to it is Legacy firmware 14.6. So I suggest you to test it too.

Kind Regards,
Robert.

by anonymous
Hello,

  

If possible, please set the RUT240 to Bridge mode, then after the issue is replicated, please log into the WebUI of the router by setting a static IP on your PC in the LAN range of the RUT240, then navigate to System → Administration → Troubleshoot and generate a troubleshoot file. This will help us determine the settings you are using and the logs that may contain some useful information. This file can be sent to me via a private message.

Perhaps you could also describe the configuration of the routers that do not work with the RUT240 in passthrough mode? Are they using DHCP to obtain the addresses?

  

Best regards,
DaumantasG
by anonymous
Hello DaumantasG,
I will try one more time to change Teltonika RUT240 from Passthrough to Bridge mode and replicate problem to check again if something changes. I will try to share T-Shoot file, but in created separate topic about it (here I don't have option due to the fact I'm not the creator/owner of this topic).

Generally speaking, configuration of every edge-router is very simple - whatever Vendor device I use: Cisco, Juniper, Huawei, Fortigate etc.
I configure following:
- interface (connected to Teltonika) set IP address to obtain it from DHCP
- create static-route/default-route to the Internet (facing Teltonika)
- check router's routing table and perform simple PING test sourced from obtained-IP-address-from-Teltonika to some Internet --> usually it's Google IP 8.8.8.8 or 1.1.1.1. Sometimes this simple PING is failing.

Topology is as follows:
Edge-router {interface-wan} (acquire IP from DHCP) ------ UTP 5 cable --- lan eth0 (Passthrough) Teltonika mo1s1a1 --- LTE network get public IP address from APN -- Internet

I suspect reasony why Passthrough is not fully working is miscorrect handling of the traffic coming to it (or some mechanism is messing with it).
What I mean is: Teltonika is correctly assigning and leasing IP address from it's DHCP Server to specified MAC Address interface in WebUI for mob1s1a1, which is OK, to behind-connected device.
Then, router not only receives it's public IP address with /32 prefix, but also small virtual public subnet /30 (4-IP address subnet) created from Teltonika-DHCP Server, where:
- first IP address -- subnet (not usable)
- second IP address -- assigned my to edge-router
- third IP address -- virtual-gateway assigned to Teltonika via which traffic will be routed to Internet
- broadcast (not usable).

This "third" virtual-gateway IP address existing to Teltonika is not usable when defining default static-route as the correct next-hop IP address, because you cannot even ping it locally from edge-router to Teltonika.
This is the clue why sometimes device's are failing. Why?

For example, let's examine Juniper routers, wherever you create static-route you have to explicitly point next-hop IP address that is resolved from Interface into usable and route'able IP address, which in this case is not working and blocking the traffic.

Cisco has no problem to define static-route and routing to DHCP service itself, so it's working OK.
ip route 0.0.0.0 0.0.0.0 dhcp

Huawei has some issue and static-route even if it's looking similar is not working :/ not sure why:
ip route-static 0.0.0.0 0.0.0.0 GigabitEthernet0/0/9 dhcp
(Gi0/0/9 is interface connected to Teltonika)

Fortigate has no issue at all it works fine.

Even that every Vendor device router/firewall should acquire from Teltonika it's default-Gateway IP (to Internet) and visible in it's IP routing table I prefer to define by myself static-defult route.

Now, with Legacy firmware 14.6 this third IP address as virtual-gateway was pingable (even locally) and you could easilly create any kind of static-route using this IP as next-hop, now with RutOS is not usable and so even Passthrough is kind of assining IP address behind-connected devices wil not have full access to Internet.

I though that firewall might be blocking, and even created extra zones as trusted everyting LAN_to_WAN and WAN_to_LAN but it's no the issue.

Finally, Zimantasbilu has informed me about my side-topic:
https://community.teltonika-networks.com/59854/solved-passthrough-teltonika-rut240-further-remote-management

In next-coming RutOS 7.5 will be patched Firewall rules etc. so I'm waiting to see if something changes also with Passthrough, as well.

Kind Regards and thanks for reading this long commect,
Robert.
by anonymous
Hello,

  

Thank you for such an extensive report.

There will indeed be some improvements to bridge mode after v7.5 of RutOS, so let's wait for that release, and if you experience any further issues we can continue troubleshooting.

  

Best regards,
DaumantasG