FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
410 views 2 comments
by anonymous

After installing the latest firmware (RUTX_R_00.07.04.2) on my RUTX11 the CLI command gsmctl could not send an SMS message.

I got the following error:

BusyBox v1.34.1 (2023-04-14 12:37:02 UTC) built-in shell (ash)

   ____        _    ___  ____
  |  _ \ _   _| |_ / _ \/ ___|
  | |_) | | | | __| | | \___ \
  |  _ <| |_| | |_| |_| |___) |
  |_| \_\\__,_|\__|\___/|____/

 ---------------------------------
   Teltonika RUTX series 2023
 ---------------------------------
root@Teltonika-RUTX11:~# gsmctl -S -s "+352xxxxxxxxx test"
[gsmctl_send_sms:20] error: ERROR: Failed to parse response
root@Teltonika-RUTX11:~# grep version /etc/config/system
        option device_fw_version 'RUTX_R_00.07.04.2'
root@Teltonika-RUTX11:~#

What can I do to avoid this error?

Regards

1 Answer

0 votes
by anonymous

Hello,

Were you able to send SMS messages before?

Does SMS sending work when you try to send it through the WebUI?

If you updated the firmware with 'keep settings' turned on, there might have been migration issues. In that case, I recommend resetting the device to factory defaults and checking if the issue persists.

In case the issue continues, please try sending an SMS using the following command: 

  • ubus call gsm.modem0 send_sms '{"number":"+37001010101","text":"ubustest"}'

If none of these suggestions helps, please:

  • Share the results.
  • Download a troubleshoot file and attach it to your question by editing it. You can download the troubleshoot file from System -> Administration -> Troubleshoot.
  • Provide the output of the following three commands (you can send it via private message if you prefer not to share this information):
  1. gsmctl -A 'at+csca?' 
  2. gsmctl -A 'at+qcfg="servicedomain"' 
  3. gsmctl -A 'at+qcfg="nwscanmode"'

Kind Regards,

Andzej

by anonymous

Hello Andzej,

Yes, I was able to send SMS before, this through WebUI and CLI.

I did a factory reset, but nothing changes.

I tried the command:

root@RUTX11:~# ubus call gsm.modem0 send_sms '{"number":"+37001010101","text":"ubustest"}'

{

        "request": "AT+CMGS=21\r0011000B917300010101F10000FF0875717D4E2FCFE9\u001a",

        "response": "\r\n> \n\r\n+CMS ERROR: 350\r\n",

        "errno": 5,

        "error": "Invalid response"

}

root@RUTX11:~#

Here are the returns of the 3 commands:

root@RUTX11:~# gsmctl -A 'at+csca?'

+CSCA: "+352021100003",145

root@RUTX11:~# gsmctl -A 'at+qcfg="servicedomain"'

+QCFG: "servicedomain",2

root@RUTX11:~# gsmctl -A 'at+qcfg="nwscanmode"'

+QCFG: "nwscanmode",0

root@RUTX11:~#

How can I send you the troubleshoot file ?

Best regards,

Robert

by anonymous

Hello,

The troubleshoot file can be attached to your original question by editing it. The attached files are only visible to Teltonika moderators. Alternatively, you can click on my profile and send me a private message and attach the file there.

Also, could you try disabling VoLTE in Network -> Mobile -> General and try sending SMS?

Kind Regards,

Andzej