FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
129 views 1 comments
by anonymous

Hello,

I am trying to change the IP address on a RUT240 via JSON-RPC to 192.168.0.1 as it is brokering between two devices with that IP range and neither of them can have their IP changed. The problem is that when I change the IP of the router, I can't access again through JSON-RPC, I have tried to restart the network service and even reboot the router, but without any success, when getting a session ID in the HTTP POST for a new connection on the new IP, it just waits until the timeout finishes. However, if I log into the GUI via the new IP, I do have access, in fact, devices can ping the router so there is connectivity.

After all, JSON-RPC sends commands through the CLI console, so I'll write down the commands I'm using:

  •  uci set network.lan.ipaddr = 192.168.0.1
  •  /etc/init.d/network restart
  •  uci commit

Do I have to wait longer? Is there any command I am missing? I would appreciate any advice or help.

David

1 Answer

0 votes
by anonymous

Hello,

 

When making changes with UCI, make sure you commit changes first and then restart the service, not the other way around.

 

Please refer to our wiki here and here and ensure that you are making the changes correctly.

 

Also, what firmware version are you using? If you are using old firmware, would it be possible for you to update to the latest firmware version with 'keep setting' turned off?

 

Kind Regards,

Andzej

by anonymous
I finally realised that the problem was not with the commands or the firmware, but with the networks that were in range. It turns out that all this was running on a virtual machine with a static IP 192.168.0.1, so when I set the same IP for the router, there was interference and the json-rpc protocol detected the virtual machine instead of the router. That's the reason I was able to access the GUI from the host machine.

In addition, I have also been able to verify that it is not necessary to restart the network service, with the commit is enough to change the IP and be able to connect again.