FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
127 views 3 comments
by anonymous
Dear all,

I'm trying to update several RUT240 remotely from version 7.03 to version 7.04.2.

The units were remotely factory reset through SMS command, therefore I'm attempting an update with the default configuration.

I used WebUI through RMS, and proceeded to the Firmware Update page, where latest version from Teltonika server is retrieved.

Some units went through the update process with no problems.

Others are stuck while downloading, and the router is then unresponsive.

I tried to initiate firmware update from RMS interface, but same thing happen: download is interrupted midway, timeouts, then unit is offline.

I also tried to upload 7.04.2 binary file from WebUI but still fails mid way.

Is it normal behiavor that unit is offline when downloading (but not updating yet!) new firmware?

Does 7.03 have some issues with firmware update? Or there is an issue with RMS?

With regards

Nick

1 Answer

0 votes
by anonymous

Hello,

This is a bit odd and it is not a known issue with 7.03.

Are there many of these devices? Do they have stable connectivity?

Could you try updating via the following methods:

  • Download a firmware image from here and upload it directly via WebUI
  • Update firmware from the server via SMS. SMS text is 'fw_upgrade' by default. For example: admin01 fw_upgrade
  • Try updating firmware via bootloader. Upload the image downloaded to 192.168.1.1/index.html

Please let me know if these methods work.

Kind Regards,

Andzej

by anonymous
Dear Andzej,

Thank you for the reply.

It looks like was some sort of packet loss that day, either with the router 4G network, your servers or the Internet.

When I tried to upgrade three units the day after, all upgrades went smoothly on first try.

So it appeared to be an intermittent issue. Will report if it happens again.

Many thanks

Nick
by anonymous
Hello,

Glad to hear. Let me know if this happens again and thanks for the update!

Have a nice day!

Kind Regards,

Andzej
by anonymous
Hi Andzej,

Unfortunately this issue continue to appear.

I'm having roughly a 30% success rate in updating units remotely to the newest 7.04.02 firmware.

The others fail while downloading the update.

If I upgrade from WebUI, I never see the validation screen; either it stalls, or the RMS "Connection unsuccesful" message appears.

If I upgrade from RMS, the update is partially downloaded then goes to timeout.

In either case, it doesn't appear to be a problem of cellular network as the signal is strong and the issue appears both on VODAFONE and WIND TRE network.

Do you have any suggestion besides going on-site to perform the update?

Do you confirm that once firmware update is launched, the unit is locked and if update fails a reboot is required?

With regards,

Nick