FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
235 views 3 comments
by anonymous
I have a TRB245 and I use it as a NTRIP client. The RS232 port is connected to my RTK-GPS receiver. I use the GPS patch antenna to send a GGA string to the NTRIP server every 5 seconds.

When the TRB245 is booted, the NTRIP connection is established and it can run fine for several hours. However, when the connection drops the TRB245 does not re-connect automatically. I have to reboot the device in order to re-connect.

What can I do so the TRB245 will automatically re-connect to the NTRIP server when a connection is lost?

I'm using firmware TRB2_R_00.07.04.2

1 Answer

0 votes
by anonymous

Hello,

I would like you to check the following. When the device disconnects from the server, login to the router's WebUI, navigate to System -> CLI or via SSH and execute the following command:

  • /etc/init.d/rs_ntrip restart

If that helps, periodic service restart can be configured.

Also, could you provide more details about disconnection from the server? Is it a loss of a single connection between NTRIP client and server, is it related to a general data connection loss on the TRB side, or is it the server that occasionally goes offline? 

Best regards,

by anonymous
I have a suspicion that the issue is related to the GPS patch antenna of the TRB245.

I've done some more tests and when I use a static GGA string, the NTRIP connection seems stable.

When I did the test with the GPS patch antenna, the GPS antenna was not in an optimal location.

I'll do some more tests to get more details.
by anonymous

After 11 hours and 33 minutes the NTRIP connection was disconnected (using the static GGA string). The reason of the disconnect is unknown. When I execute /etc/init.d/rs_ntrip restart the NTRIP connection is re-established.

However, I don't like the periodic service restart solution because it will still result in downtime. For example when you set the restart period to 5 minutes, then in worst case the NTRIP connection can be disconnected 4 minutes and 59 seconds.

by anonymous

After the next disconnect occurs, before rebooting anything, I would like you to generate and attach a troubleshoot file to your question. Make sure the issue is present, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. 

The logs in the file might provide more insight into the issue. I would also forward it to the developers to look into and also request to implement some reconnect mechanism in future firmware releases.

Best regards,