subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
124 views 0 comments
by anonymous
Hi, we have been using various RUT series routers now for a deployable 4G solution we have built. In particular, the (950 and 955) However, we have noticed a number of issues with these, in particular, WAN connectivity. We have been using this WAN port in order to use a Starlink Internet terminal in the field, as a main connection and then using LTE forf failover. 
However, 95% of the time, the WAN connection will not register. Sometimes after a full factory reset the WAN port will come up and an address will be issued via DHCP to the RUT from the Starlink terminal. If the WAN connection is then disconnected and re-connected, the WAN port will not come back up, even after powercycle. 
This problem is present on both the older firmware and newer firmware, with the new GUI. All units have been on latest firmware.
Its worth noting, that we have tried a number of other IOT / M2M routers- Inhand networks and NetComm and BOTH of these have worked flawlessly without fail- connecting and disconnecting the WAN cable- everytime the link comes back up and DHCP is working as it should.
As a result of the above issue, we have currently had to stop using teltonika products, as this is a major roadblock for our project. I am assuming becuase the majority of your customers use the RUT series for LTE and not so much for WAN, this issue has gone undiscovered. 
We are holding off testing the RUT 5G router, due to the likelyhood of these same issues being there- it seems to be a firmware / software bug, as apposed to a hardware one.
I can provide log files, but I would imagine there is nothing to see in the logs. 
I have also noticed, often the WAN / LAN port LED remains on and blinking, even when no cable is connected.
Perhaps this scenario can be replicated in your lab, using any kind of internet connection via cable over WAN port. 
TO confirm, we have also ensured the WAN / LAN port is configured to WAN...

1 Answer

0 votes
by anonymous
Be advised, that the RUT955 is supported to run "official" openwrt. Which is worth for you, to give it a try.

I have a large fleet of such RUT955, running very custom "official" openwrt, in the are of IoT, connecting to AWS-IoT via WiFi/WAN/WWAN with auto-failover, low level sensors via ModBus/RTU, data queuing, firmware update OTA etc.

Besides simpler, and more reliable customization of the firmware for the RUT955, there is the advantage of newer packages in use, newer kernels etc. And lot of standard linux utilities for bug tracing. Finally, large crowd support.

You might try to flash one standard image of "official" openwrt to one of your devices, connected to starlink.

BTW: There was (or still is) a speciality of the "Dishys" dhcp during connection establishment, issuing a temp IP for the connected router (RUT955) for a very short period of time, 5s, only. Which was (or still is in Teltonikas stuff) not properly handled. An indication for this bug _could_ be seen on the RUT955, showing a non_CGN IP for the RUT, like

Another possible issue is the wrong handling of DHCPv6 replies from the "Dishy", which often might be blocked because of a bug in the RUTs standard firewall.