FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
250 views 0 comments
by anonymous

Hi,

on TRB145 with firmware TRB1_R_00.07.04.1 I cannot safe the remote access settings. Even when I select the certificate and key I am getting the message "Server certificate" and "Server key" files are both required.

This occures with default values and those of generated certs through the certificate manager. Any ideas? Thank you.

Cheers

Philipp

1 Answer

+1 vote
by anonymous

Hello,

This appears to be similar to a known issue, which is planned to be resolved in 7.5 firmware version.

Device reset to factory defaults should resolve it, as it is likely caused by a firmware update with Keep settings option enabled.

Otherwise, to solve this without losing current configuration, you will need to login to the router via SSH. For options, on how to SSH into your device, refer here.

Next you will need to execute the following command, to edit a certain configuration file:

  • vi /etc/config/uhttpd

Press letter i to enable editing and replace the following lines:

  •  list listen_http '80'
  •  list listen_https '443'

To 

  •  option listen_http '80'
  •  option listen_https '443'

Once done press Esc, then enter :wq and press Enter.

Lastly, restart the service with /etc/init.d/uhttpd restart command.

This should allow you to save. 

Best regards,