FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
+1 vote
747 views 3 comments
by anonymous

Hello!

I am using a RUT240 and want to start using Teal physical M2M eSIM's.

As per this (https://wiki.teltonika-networks.com/images/a/aa/1oT_eSIM-Test_Teltonika-RUT240.pdf) test report, the RUT240 should fully support eSIM functionality:

"...

The Teltonika RUT240 features a Quectel EC25-EC cellular module which supports needed SIM Toolkit(STK), and Bearer Independent Protocol(BIP) features for Remote SIM Provisioning (RSP).

While the RUT240 comes with a mini-SIM card(2FF) slot, it can easily be used with 1oT plastic eSIM, which enables you to Over The Air swap carrier profiles. 1oT eSIM improves the reliability of the Teltonika RUT240 router by making sure that you have future-proofed the connectivity.

You can configure the main router settings in the user interface, the cellular modules are controlled via AT-commands, and you will need to have access to the AT-command terminal.

..."


I have accessed the AT-command terminal on my RUT240 and the first required AT command goes through succesfully:

gsmctl -A AT+QSTK=0
CLI response = "OK"

The second command however, results in an ERROR:

gsmctl -A 'AT+QCFG="bip/auth",1'
CLI response = "ERROR"

The brand new Teal M2M eSIM's in question will not "latch" to a network when installed into the RUT240.

So it will not provision on the network for activation.

The RUT240 recognizes the SIM card as "inserted" and reports the proper IMSI and ICCID.

RUT240 factory reset/ set to default settings.

All mobile networks settings set to "auto" or defualt. 


-Any ideas?

EDIT: -UPDATE-

So, Teal support responds fast!

The support desk asked me for the eID of the eSIM I was trying to get activated in my RUT240;

As I understand it the workflow works as follows:

!Brand new Unactivated eSIM goes in a device for the first time
>the eSIM "self provisions" 'automatically' onto its "Global Roaming" Network Plan (so that brand new esim's can self provision anywhere in the world)
   >after latching to 'any' cell tower and provisioning as a 'Global Roaming' the user changes the APN to "teal" (no quotes)
        >After this is done, the eSIM sends a "heartbeat" to the Teal Cloud servers, and the user can see that eID as "Online" in the Teal user dashboard
            >The user then selects their desired Network Plan in the cloud dashboard and the freshly activated eSIM is automatically provisioned OTA (over the air) by the Teal cloud servers with the selected Network Plan.

For whatever reason, the eSIM would not auto provision onto the Global Roaming network for me. Bummer.
Teal support asked me for the eID of the eSIM I had installed in the device.
Once I provided this to support, they "activated" the eID for me on their end.
They asked me to change my APN to "teal" and reboot the device.
After reboot, the device very quickly provisioned itself onto the Global Roaming Teal Network Plan
(this was after I had done many factory resets, and rolled back my RUT240 firmware from the latest release, to the current production release, so any AT commands I had tried previously had been cleared out; that is to say, after Teal activated the eSIM on their end, no AT commands were required on the RUT240, it was literally in factory defualt configs with the production release firmware)
-WIN- 

Okay, at this point, I selected my desired Network Plan in the user dashboard, clicked apply, and crossed my fingers.

Literally magic stuff.

After ~10-15 mins my RUT240 automatically provisioned onto the AT&T 'home' network (not roaming) -this is the plan I selected.

I am seriously impressed. 

I asked the Teal support team if I am going to have to have them actiavte all the eSIM cards I want to use in RUT240's if I cant figure out how to get the AT commands to fire, and I will update this thread with their response.

Furthermore;

What the AT commands are actually trying to accomplish:

Enable the STK (SIM Tool Kit) embedded in the LTE modem inside the RUT240
Enable the Bearer Independent Protocol (BIP) which is required for Remote Sim Provisioning (RSP)


As I gain more info I will reply here;

I still want to find some kind of answer as to why the AT commands from the Teltonika IoT eSIM test report (literally FOR the RUT240) dont work on MY RUT240.

 

1 Answer

0 votes
by anonymous

Hello,

While I cannot replicate your scenario since I do not have an eSIM, I tried to replicate the AT commands (latest firmware version):

Both of the commands were executed successfully. Could you please check if you are entering the correct command? Also, if you are pasting a command, please, try entering the commands manually.

Kind Regards,

Andzej

by anonymous

RUT240 latest firmware; RUT2_R_00.07.04.2

Commands entered via SSH

Commands manually entered (not pasted) 

Screenshot to show results:



-Any thoughts?

by anonymous
Hello,

I will send you a private message.

Kind Regards,

Andzej
by anonymous

Just wanted to follow up on this for anyone else reading this thread:

Teltonika support was able to confirm the AT commands were not working on my RUT240 due to old modem firmware on my unit.
-after upgrading modem firmware, AT commands now work as intended.

From Teltonika:

"Usually, modem firmware updater is rarely recommended as it has a small chance to cause issues."

Perform the below process at your own risk.

**IMPORTANT**
-the RUT240 needs stable internet connection to perform the upgrade
-do NOT use the cellular WAN interface for internet connection for upgrade
(the cellular interface will loose connectivity during the upgrade, and this can lead to corrupted modem firmware if it is being used as the internet connection for the upgrade)
-DO use an alternate -stable- WAN connection
-eg: Ethernet WAN, WiFi as WAN, Ethernet LAN on a local network with stable internet access, etc.

Log into the unit via SSH/CLI and enter these commands:
 

opkg update 
opkg install modem_updater
opkg install sshfs
modem_updater -g
 

(command line instructions here: https://wiki.teltonika-networks.com/view/Command_Line_Interfaces_RutOS) 

Now, the last command (modem_updater -g) should output a list of available firmware versions for your modem and other information used in the next command. Then you can update the modem's firmware via the following command: 

modem_updater -i (...) -v (...)

For example, if the output of 'modem_updater -g' shows 'USB ID: 1-1' and the latest firmware, based on the numbers, is EG06ELAR04A08M4G, then, the correct command would be:

modem_updater -i 1-1 -v EG06ELAR04A08M4G 

**You will see different versions according to your modem** 
-In my case, the modem firmware contained '06A09M' in the firmware version, your unit may have a different interal modem model (global vs. north america for example) in which case yours may be different than mine.
-In any case, select the "latest" firmware presented to you by the 'modem_updater -g' command 
-The process will take a while.
-Ensure the internet connectivity and power to the device are both stable.

Good luck and happy upgrading :D