FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
301 views 8 comments
by anonymous
So if i disconnect from rutx11 and Connect to my phone from tv then netflix works fine. So something in the router is causing this. Same operator som Cards so not the sim

2 Answers

0 votes
by anonymous
Hello,

  

Thank you for reaching out!

Could you clarify what kind of error are you receiving when playing Netflix over the RUTX WiFi?

Just for future reference, I will also ask you to navigate to System → Administration → Troubleshoot and generate a troubleshoot file. This file can be attached to the original question and will only be visible to Teltonika moderators.

Perhaps the signal level is quite weak on the RUTX11? Or maybe the TV is too far away and the WiFi signal is not sufficient? Are other applications on the TV working fine?

Awaiting your response!

  

Best regards,
DaumantasG
by anonymous
The signal is fine, youtube works fine. I think this happened after an update to the rutx11
by anonymous
Hello,

What about the rest of the questions? What kind of error are you receiving on Netflix? Could you attach a troubleshoot file as well?

Best regards,
DaumantasG
by anonymous
Code is nw 2-5 sorry Iam not near the router at this moment
by anonymous
This error seems to point to DNS issues.

When you can, log in to the WebUI of the router, navigate to Network → Interfaces → General, and edit the LAN interface. In the DNS Servers field enter 1.1.1.1, then press a + sign, and in the second field enter 8.8.8.8. Press Save & Apply and check if Netflix loads correctly.

  

Best regards,
DaumantasG
by anonymous
I already did that, but the tv seems to still get the router as dns ip
by anonymous

Hello,

  

You could try disabling the DNS server completely by using the commands provided here. This will delete the DNS server of the router, and will only provide the specified servers to the clients. If your network is IPv4-only, disabling the dnsmasq is enough. Please keep in mind, that LAN hostnames will no longer be resolved when the router DNS server is disabled.

Alternatively, you could try setting custom DNS servers on your TV directly.

  

Best regards,
DaumantasG

by anonymous

Exact the same problem here. I can play Youtube but I can't play Netflix and NLziet anymore on my AVTex LG-WebOS-based SmartTV but I can on my iPhone which is connected to the same Wifi/mobile network trough the Rutx11. This happens after updating to RUTX_R_00.07.04.3 (both without or with erasing settings). Also RUTX_R_00.07.04.1 has the same issues. Netflix gives an error  "Code NW-2-5" and NLziet starts the main menu but when I try to start a stream it wil never starts. Speedtest over the mobile connection in the Rutx is 88.3/42.5 with a latency of 26ms.

If I disable the mobile interface on the Rutx11 and connect to a WiFi hotspot on the Rutx11 everything works fine again (without editing any other settings). On older firmware versions of Rutx11 there were no problems with connecting to Netflix of NLZiet (in fact if I downgrade to RUTX_R_00.07.03.4 or lower everything works out of the box again.

I tried all kind of things with manual enter DNS servers (8.8.8.8 and 8.8.4.4) on the Ethernet interface, enter DHCP option6 for DNS server (and force them) but no luck at all.

The solution of changes on the CLI I am not really a fan of because most of the time these changes disappear with a firmware update or factory reset. I am pretty sure this undocumented 'feature' was added in the latest firmware versions.

I fact I am really disappointed about the Rutx at this point. Also the Wireguard (client) implementation is a pain in the butt. It's (Wireguard) a piece of cake on my Macbook and other (mobile) devices but on the Rutx it never really works.

by anonymous

Hello,

  

I'm sorry to hear that we did not meet your expectations for our devices!

The issue is most likely with the MTU on the mobile side of the connection. I will ask you to navigate to Network → Interfaces → General, edit the mob1s1a1 interface, open the advanced settings, and change the Override MTU option to 1420. If that does not help, try lowering it.

If that does not help, try a lower MTU value, but keep in mind, that setting it too low could also cause some issues.

Let me know if that helps!

  

Best regards,
DaumantasG

0 votes
by anonymous

Hi DaumantasG,

Actually your solution (lowering the MTU of the mobile interface to 1420) works. So thanks for that.

What I don't understand is why it was working out of the box with firmware version 7.03.xx The MTU of the mobile interface was default which means 1500 and that worked fine???

Best regards,

Robertus