FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
806 views 6 comments
by anonymous

Hi

My RUT240 won't update - it says the server is not available, and when I download and try to use the firmware file it gives an error that the image is not in the correct format.

I have tried all the update files available with the same result. 

My SIM won't register to the EE network which is why i am updating in the hope it will fix this.

Troubleshooting file attached.

https://community.teltonika-networks.com/?qa=blob&qa_blobid=9081177652566669639

1 Answer

0 votes
by anonymous

Hello,

Which versions have you tried specifically? It might be that the version you have is simply too old to accept current RutOS firmware. Could you try updating to 1.14.6 first, which can be downloaded here?

You could try updating via CLI, following instructions provided here.

Another option is to update via bootloader menu, as instructed here.

Best regards,

by anonymous
Thanks so much for your reply. Although I did start with the oldest update I could find on the website, the one you supplied did indeed work, and I'm now running the latest firmware.

I'm still having issues connecting to the mobile network however - I've got two sims, one EE and one 3.

Although they detect properly and the network shows as available, the modem can't seem to connect and moving between interface pages I get a "modem busy - connecting to carrier' message.

The modem is showing a series of three cycling lights, then after a bit all three flashing together.

I expect there are some mobile network specific settings i need to tweak...
by anonymous

For one, you might need to specify your provider's APN in the router settings. This can be done by logging to the router's WebUI and navigating to Network -> Interfaces -> General. Next, edit mobile interface settings, in the configuration window, if set, disable Auto APN option, and enter custom APN, based on your provider.

Otherwise, if connectivity issues persist, I would like you to attach a troubleshoot file to your question. Please, replicate the issue, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. The logs in the file might provide more insight into the issue.

Best regards,

by anonymous

Thanks again. 

I've adjusted the APN setting but it doesn't seem to make any difference. 

Not sure how to upload the troubleshoot file, will try to link to here.

https://community.teltonika-networks.com/?qa=blob&qa_blobid=2835044063219297836

by anonymous

Hello,

Your SIM has a setting to connect to operator with a code 23420, which corresponds to Three UK, not EE, which would be 23430.

Also, in the router's Network -> Mobile -> Network Operators page, have you tried setting Connection mode to Auto?

In addition, mobile signal characteristics in the logs file are poor. Are you able to connect to the operator and establish data connection, if the SIM is inserted in a smartphone? 

Best regards,

by anonymous
Thanks again for your reply. I have several SIM cards, EE, 3 and Vodafone and I have tried all of them. They all work and connect correctly when I insert them into my iPhone.

I have tried auto but it doesn't seem to make any difference.

I wonder if a reset will help?

Matt
by anonymous
You can try that, but I doubt it will help to resolve the issue.

Another thing that can be attempted is the update of internal modem's firmware, as based on the data from the files you have previously provided, it is quite dated.

I have sent send you instructions in a private message.

Best regards,