FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
82 views 0 comments
by anonymous
Hello Teltonika users!

I have a strange usage scenario, well I assume it is alien to most of you. I use a RUTX10 in a mobile setup for event technology such as video livestreaming, audio engineering, and lighting control. One subtask of this is that I transmit Art-Net UDP broadcast messages from a sending Art-Net Node such as QCL+ (software running on Windows, OS X, or Linux) or ENTTEC ODE.

I found out that as soon as I have more than 4 clients on the 2,4Ghz Wifi, I get massive dropouts on the UDP broacast. In this scenario, I had 3 air2dmx Art-Net receivers and 1 Windows laptop plus 1 Linux laptop on the Wifi.

I can work around the issue by putting the laptops on the 5Ghz Wifi, but the air2dmx receivers can only do 2,4GHz. However, it's still risky since I need to guarantee that I have no more than 4 Wifi clients on 2,4Ghz at any time. Another drawback is that in some cases I have to use the 5Ghz interface to be in client mode, then it can't use this workaround.

Now my question is: Is this a limitation of the hardware? After all, on the LAN port broadcasts are easily dumped out, on the Wifi they need to be sent to each and every client seperately… or is there anything I could configure in the user interface of my RUTX10?

I would really like to insist on using UPD broadcast mode for Art-Net since it basically allows for hot-plugging of any receiving node that supports DHCP.

The amount of traffic should be below 200kbps as far as Art-Net is concerned.

Looking forward to your ideas.

Best

Zwerg

1 Answer

0 votes
by anonymous

Hello,

  

RUTX10 should definitely be able to handle 4 clients (much more than 4).

After reading up on the AIR2DMX interfaces, it seems like they only support 802.11g, which should not be an issue, but just to check, could you enable legacy mode in the wireless settings of the RUTX10? This can be done by navigating to Network → Wireless, editing the global 2.4GHz settings, and setting the mode to Legacy. If the behavior is still the same after this change (WiFi crashing), make sure to set the mode back to N.

Also, make sure you are using the latest firmware (a factory reset is also recommended, if possible).

If setting the mode to legacy does not help, I will ask you to replicate the issue, navigate to System → Administration → Troubleshoot and generate a troubleshoot file. This file can be attached to your question and will only be visible to Teltonika moderators. It will provide me with your configuration and the logs, which may indicate where the issue lies.

Also, on the Air2DMX description page, it mentions two modes - Stand alone HotSpot Mode and Router Mode Sign in to existing Wi-Fi. Could you clarify which one you are using? All of our devices have a limit of 4 Wireless STA instances, thus the devices should connect to the RUTX10, rather than the other way around.

  

Best regards,
DaumantasG