FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
889 views 0 comments
by anonymous

1 Answer

0 votes
by anonymous

Hello,

I assume that you are not redirected to the captive portal, when your router connects to some hotspot as a wireless client station. You should be redirected, but if you are not, below are a few suggestions you can try:

  • Update your router's firmware to the latest;
  • Login to router's WebUI, navigate to Network -> DNS and disable Rebind protection option.
  • After connecting to the hotspot, login to the router via SSH, execute the command below:
    •  cat /tmp/resolv.conf.d/resolv.conf.auto
    • It will list DNS server IP address, associated with hotspot interface. Manually set DNS on your computer by using this IP.
  • Increase TTL value by one. Login to the router via SSH, execute the command below: 
    • iptables -t mangle -A PREROUTING -i wlan0 -j TTL --ttl-inc 1

See if that helps.

Best regards,