7591 questions

9029 answers

14584 comments

11836 members

0 votes
1,779 views 9 comments
by

Hi,

we would like to control power Input & Output with Teltonika RUTX09 but have problems to use In-put/Output of Teltonika RUTX09.

There is no entry in RUTX09 Teletonika Wiki like for Rut2xx Wiki

gpio.sh command does not exist on latest Firmware RUTX_R_00.01.04.1 and there is no State button in Output Web interface

Could you please explain how Input/Output works on Teltonika RUTX09?

Best regards

1 Answer

0 votes
by

Hi,

Input/Output on RUTX09 works exactly the same as on RUT240. You can control it under Services - Input/Output. 

For more information, for now, you can refer to the RUT240 article. To connect to something like a relay, you could use this example:

If you have more questions regarding this, shoot me a PM.

Best answer
by

Hi,

thanks for your answer to my question.

On wiki routers are described differently:

RUT2xx
This section provides a list Input/Output electric characteristics inherent in RUT2xx routers:
Digital non-isolated input (DIN1): Logic low 0 - 5 V; Logic high 8 - 40 V
Digital open collector (OC) output: 30 V, 300 mA

RUTX08, RUTX09
This section provides a list Input/Output electric characteristics inherent RUTX08 and RUTX09 routers:
Digital non-isolated input (in power socket): Logic low 0 - 5 V; Logic high 8 - 40 V
Digital open collector (in power socket) output: 30 V, 300 mA

The screenshot I attached does not show any button in Output like its shown on https://wiki.teltonika.lt/view/RUT2xx_Input/Output Does the button appear when the something is connected?


Connecting the external device like shown on your screenshot does not work for me.

Can you please provide me the steps how to correctly set up Input/Output on RUTX09? I don’t want to damage the device

Best regards

by

Hi,

On RUTX09, input and output pins are in the same location as on RUT2XX. 

You can find more information about this on our Wiki Teltonika page for RUTX09 powering options: https://wiki.teltonika.lt/view/RUTX09_Powering_Options

When it comes to WebUI, try refreshing it with CTRL + F5, which ignores the cached data

by

Hi,

according to to all the infos I have my setup should work with connecting the external device ground to Pinout 4 of Teltkonika RUTX09, correct?

##################### Pinout 1 (Power) ---- (Power) + ############################ (Power) +
# Teltkonika RUTX09 # Pinout 2 (Ground) ---(Ground) - # Meanwell 24 power supply #    |
#####################                                 ############################    |
  Pinout 4 (Output)                                                                   |
          |                                                                           |
          |                                            ###################            |
           ----------------------------------------- - # external device # (Power) + -
                                                       ###################


My external device does how ever not get any power automatically via Teltkonika RUTX09. Do I need to activate Pinout 4 (Output) on Teltkonika RUTX09 web interface? (Output button State On/Off does not exist on Teltkonika RUTX09 web interface)

Could you please describe me the steps how to activate Pinout 4 (Output) on Teltkonika RUTX09?

Best regards

by

Hi,

Your setup should work and yes, you should enable it on router's WebUI like shown in the picture below:

Weirdly, this doesn't show up on your router's WebUI. Could you try refreshing with CTRL+F5, use incognito mode try a different browser?

by

Hi,

yes, it is this. This is the my result testing Firefox, Chrome (latest build) & Internet Explorer as well as in incognito mode.

gpio.sh on commad line is not available either

by

Could you try to reinstall the firmware? Preferably, without keeping the settings. You can find the file for the latest firmware on our Teltonika Wiki page: https://wiki.teltonika.lt/view/RUTXxx_Firmware

by

Reinstalling the firmware without keeping the settings helped. I do now have the button. Thanks for the hint wink

I have connected everything like shown in my previous comment to a 24 V power supply. The external device is able to get power from the power supply and its ground is connected to Teltkonika RUTX09 Pinout 4 (Output). If I click the button digital output on/off nothing happens.

I would like to achieve to that I can power on/off the device via Teltkonika RUTX09. These are my settings on the output

Are they correct?

by
Could you draw me your circuit? Or maybe even take a picture?
by
Thanks for your continuous support. I have sent you PM