FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
136 views 4 comments
by anonymous
Dear support team,
the SMS commands mobileon / mobileoff worked fine with FW 7.02.07 (and earlier), used on many RUT955. But with recent FW 7.04 it doesn't work (nothing happends), although event log shows that SMS received and system log shows "kern.notice kernel: SMS received from: +XXXXXXXXXX (internal modem)". But no other log records.
What is wrong or changed in new FW?

1 Answer

0 votes
by anonymous

Hello,

I have tested a couple of different devices with the latest 7.04.2 firmware, with a couple of different operators, but was unable to replicate the issue. In every case commands were executed. 

Could you specify, if tests were performed on 7.04 or 7.04.2 firmware version. If it was 7.04, could you update to the latest and try again. 

Also, could you reset one of your devices to factory default settings and try SMS commands?

If the issue persists, I would like you to generate a couple of troubleshoot files and attach them by editing your question:

  • Downgrade one of the devices to 7.02.07, send a couple mobileon/mobileoff messages, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. 
  • Upgrade the same device to 7.04.2 with Keep settings option set to off. Send a couple mobileon/mobileoff messages, download troubleshoot file. 

Comparing device configurations might provide more insight into the issue.

Best regards,

by anonymous
Ok, took new RUT955, upgraded to FW RUT9_R_00.07.04.2 (keep settings option OFF), set authorization for SMS mobile commands to "no authotrization", reboot.
After reboot sent SMS "Mobileoff", but nothing happend.
The last idea - keep small letters case ("mobileoff"). And it works!
I'm sure that previous FWs were case insensitive. Have you change it since FW 7.04?
by anonymous

Hello,

It is good to hear that you have managed to resolve the issue.

I have personally never tested the commands with capital letters, but both, Wiki page, and router's Services -> Mobile utilities -> SMS utilities page have always listed SMS commands in lower case letters. That is how they are intended to be used.

Best regards,

by anonymous
I understand. But, on second hand, when you writing SMS on mobile phone, the dictionary "AI" changes case of letters (typically first letter big in sentence). It is not comfortable to watch case of all letters.

Moreover, log in router doesn't provide info like "SMS command declined because doesn't fit". So the user doesn't know why the router doesn't proceed the command.

Would be usefull to accent that change of case sensitivity on Wiki page as well as in change log. It will solve many troubles itself.
by anonymous
Thank you for the feedback.

I will ask to update documentation,

Best regards,