FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
388 views 2 comments
by anonymous
Hello,

I have a problem with the VPN connection using IPSec. The VPN connection works without any problems. The local network of the RUT950 is 10.0.0.0/8. The local network at the other end (Lancom 9100) is 10.1.0.0/16. The VPN works so far.

Following question:

How can I set up the RUT so that it registers with the virtual network 10.2.16.0/24 on the opposite side when the VPN is set up?

Already tried via iptables, but that failed.

Does somebody has any idea?

Greets

1 Answer

0 votes
by anonymous

Hello,

I assume the 10.2.16.0/24 network is on the Lancom side.

Add this 10.2.16.0/24 network on the Lancom as a local network, then add this same network on RUT950 to 'remote networks' to match. This way, IPSec will know that there are two remote networks available via IPSec.

However, each network requires a separate SA. So for this to work, you also need to enable Compatibility mode on RUT950 in IPSec -> Connection settings -> Advanced settings.

Kind Regards,

Andzej

by anonymous
Thank you for the hints. Unfortunately it still doesn't work. The Lancom has the local IP 10.1.1.254/24. The RUT950 has 10.0.0.254/24 as local IP. When the VPN tunnel is set up, the local network of the RUT should be mapped in the VPN and the RUT in the VPN should then be accessible under 10.2.4.254/24, for example. Where do I have to enter something?
by anonymous

Hello,

Are you looking to use netmap?

Would it be possible for you to provide a simple topology and a troubleshoot file from RUT? Troubleshoot file can be downloaded from System -> Administration -> Troubleshoot. You can attach the file by editing your question. The attached files are only visible to Teltonika moderators.

Kind Regards,

Andzej