8298 questions

9759 answers

15542 comments

13863 members

0 votes
968 views 2 comments
by
Hi,
I have a RUT955. The changelog of the new firmware RUT9XX_R_00.06.03.2 says: changed writing register numbers for Modbus. Where can I find the description of the changed writing register numbers for Modbus in RUT9XX_R_00.06.03.2. I'm having problems accessing the registers. More than half of the registers don't work anymore after updating to the new firmware.
regards

1 Answer

0 votes
by
Hello,

Thank you for your information we checked all registers ( https://wiki.teltonika.lt/view/Monitoring_via_Modbus#Getting_router_parameters ) with "ComTestPro" and everything works jsut fine. Can you please tell us in more detail what registers exactly are not working? How this issue reappears? Have you configured Modbus TCP correctly? Connect to router via SSH and type: ps | grep modbus and see if service will be stared. you should receive something like this:

root@Teltonika-RUT955:~# ps | grep modbus
24641 root      3168 S    /usr/sbin/modbusd -a 0.0.0.0 -p 5000 -m 8 -i 1
26125 root      1536 S    grep modbus
by

Hi,
ps | grep Modbus works. What I have tried further:
Downgrade to FW RUT9XX_R_00.06.02, and all Modbus registers worked as desired. I'm testing with Simply Modbus TCP Client 8.1.1 (freeware) and I've written an application with AdvancedHMI. This also works without problems with the old firmware.

Then I installed the latest firmware and made a router reset. After that again the same problems. Of the write registers only the numbers 201 and 202 work.

I also have problems reading with my application register number 3 (mobile strength dbm). I can not read the whole register to make it work, only the last 16 bits. This worked without problems with the old firmware.

With the currently active SIM card slot (register 87) the same problem, I can not read this with my application and with the new firmware.

After that I installed an Ubuntu VM and did the following tests with the write registers. Registers 201 and 202 worked, the others had an error message.

Test result OK:
modbus write -w -p 502 192.168.1.1% MW201 1
modbus write -w -p 502 192.168.1.1% MW201 0
modbus write -w -p 502 192.168.1.1% MW202 1
modbus write -w -p 502 192.168.1.1% MW202 0

Test result ERROR:
modbus write -w -p 502 192.168.1.1% MW210 1
modbus write -w -p 502 192.168.1.1% MW210 0
modbus write -w -p 502 192.168.1.1% MW211 0
modbus write -w -p 502 192.168.1.1% MW211 1
modbus write -w -p 502 192.168.1.1% MW212 0
modbus write -w -p 502 192.168.1.1% MW212 1
modbus write -w -p 502 192.168.1.1% MW212 2
modbus write -w -p 502 192.168.1.1% MW220 1

Always the same error:
/var/lib/gems/2.5.0/gems/rmodbus-1.3.3/lib/rmodbus/slave.rb:249:in `query ': The data address received in the query is not an allowable address for the server ( ModBus :: :: Errors Illegal Data Address)

Please check this.
regards

by
I got similar behavior after update from previous firmware. Got a working configuration on more then 20 RUT955 with older Firmware and after update the read out for signal strength is not working anymore.

I am using MBE PowerTool to gather signal strength information. Starting address 40004, Ending address 40005, getting with old FW in HEX FFC9 FFFF for -55dBm but on a newly updated RUT955 I get FFB0 0000 for -80dBm.

So the first 4x4 bits is as usual, but the last 4x4 bits is zeroed compared to ones. The position of bits might be strange due to byte/word swap.

Sadly I have no solution yet.