FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
159 views 4 comments
by anonymous

I am using RUT240 with the firmware version RUT2_R_00.07.04.2. I have to do some tests to make sure that the router does not emit radio frequency waves. To do this, I have a sim inserted and configured, when I ping for example to google DNS (8.8.8.8), I get a response that there is connectivity, so radiofrequency waves are being emitted. To stop this, from the terminal I have stopped the gsm service with the command /etc/init.d/gsmd stop, however, if I ping again I still have visibility. Is there any way to stop the radio frequency either from software or from the hardware itself?

If not, how can I shut down the entire router and turn it back on. I've tried using the poweroff command, but it won't turn back on, the only way is to unplug and plug the power back in.

Kind Regards,

David

1 Answer

0 votes
by anonymous

Hello,

    

As the router was not designed to have the modem stopped, to achieve this a crontab may need to be used.

It depends on what modem is in your device but for the most common modem, the command to shut it off would be

gsmctl -A 'AT+QPOWD=1'

This command will cause the modem to turn off, however, after some time it will come back up. While we cannot guarantee it will stay off, we can add this command, along with a few others to a Crontab in this particular order:

gsmctl -A 'AT+QPOWD=1'

service gsmd stop

service mobifd stop

I'd recommend running this crontab every hour, and if you notice that the modem is coming back up in this period, it can be lowered to 30 minutes, etc. If this does not help, I'm afraid there is not much more we could do other than physically unplugging the router.

Make sure to disable WiFi as well during these time periods.

   

Best regards,
DaumantasG

Best answer
by anonymous

Hi DaumantasG,

First of all, thank you for your quick response. As far as I could see, only the first command gsmctl -A 'AT+QPOWD=1' was enough, there is no more visibility to the internet. It took a few minutes to reconnect. However, as well as it can be used to shut down the modem, is there another one to force startup? 

I would like to be able to control when to turn it off and on, regardless of whether it restarts after a while, since I'm doing all this from python, through the json-rpc protocol, so I'm really sending it through the command line, i mean, the functions you mention are useful, but not the crontab as such. 

On the other hand, I would like to know what the mobifd service consists of, I understand that it contains the configuration of the SIM card.

Best regards,

David

by anonymous

Hello,

    

I recommended stopping gsmd and mobifd just as a precaution, in case they would be able to "wake up" the modem, but it appears that the power is cut to the modem and it completely disconnects and automatically reconnects after a minute or two (at least on RUTX50).

So the command to power off the modem would need to be run quite frequently, and there is no way to wake up the modem from the software.

However, I believe I found a better solution for you. Instead of powering down the modem, you could simply put it into airplane mode. This can be done by running the command

gsmctl -A 'AT+CFUN=4'

After this command is run, mobifd and gsmd will most likely need to be stopped, as they will set CFUN back to 1.

To put the router back into full functionality mode, use this command:

gsmctl -A 'AT+CFUN=1'

Let me know if this method works any better!

  

Best regards,

DaumantasG

by anonymous

Hi DaumantasG,

I have good news, It works perfectly. Searching for the meaning of the gsmctl command, moreover that puts the modem into airplane mode, it does exactly what I want, disable the modem from receiving and transmitting RF signals. Guide - AT+CFUN.

As you said, I stopped mobifd and gsmd services and, for 20 minutes (the test i did) it didn't reconnect. To set CFUN back to it's full functionality (setting it back to 1), is necessary to start gsmd and mobifd services again or it print an error.

I'm very grateful for your help, thank you so much.

Best regards,

David

by anonymous
Glad I could help!

P.S. gsmctl command is used for gathering various modem parameters, and gsmctl with the -A argument can be used to send AT commands to the modem.