8290 questions

9757 answers

15535 comments

13843 members

0 votes
2,430 views 7 comments
by
Hi,

I have trouble setting up my RUT240 (with latest firmware - 00.01.07.1) with mobile bridge to my DD-WRT router.

I have DHCP enabled on my router on its WAN port. I (triple checked) copied the WAN ports correct MAC address in the "Bind to MAC" field for the bridge mode config.

Changed RUT240 to 192.168.2.1 ip.

But also as the sys logs show my router gets an IP in the RUT240s subnet assigned instead one from my ISP.

The LTE status shows registered, but disconnected once i enabled bridge mode. And it stays like this no matter even if bridge mode is changed back to something else.

I also disconnected both devices from the power circuit for a few minutes just to make sure.

So why i am still getting a wrong IP assigned?

Thanks in advance.

1 Answer

0 votes
by
Hi,

I tested it with this firmware and it seems to work as expected. However, the state should not be 'disconnected'; it's why your other router doesn't get an IP. If you change from Bridge mode to NAT you still get disconnected? Even after you reboot the router?

Can you provide the router's Troubleshoot file taken when it is Bridge mode? It can be downloaded from the router's WebUI, System → Administration → Troubleshoot page.
Best answer
by

If you change from Bridge mode to QMI you still get disconnected?

The QMI option is always set by default. Independently from bridge/NAT/passthrough mode set. Or do i misunderstand something here? They are not mutual exclusive.

The LTE connection state is disconnected as soon as i enable bridge mode. The only way i could get it back to work is a factory reset and do the whole configuration procedure over again. Even a manual reboot of the internal modem or reregistering or reconnect via the WebUI doesn't change anything.

by
i have sent you the troubleshoot file via PM
by

Sorry, what I meant to say earlier was 'NAT', not 'QMI'.

Thanks for the Troubleshoot file. According to this you have not configured Bridge mode and the mobile WAN interface is disabled - so that's why it is disconnected.

In order to use Bridge mode:

  • Go to the Network → WAN page and set mobile as main WAN.
  • Click the "Save" button.
  • Check to see if mobile interface is connected and you receive an IP address (you can do that in the Overview page).
  • Go to the Network → Mobile page.
  • Select "Mode: Bridge".
  • Enter the other router's WAN MAC address into the "Bind to MAC" field.
  • Save the changes.
  • The other router should receive an IP address in about a minute.
After this you will no longer be able to reach the RUT router via LAN, since using Bridge mode disables the DHCP server. If you'll need to reach the router, you will have to set up a static IP configuration on your PC.
by

ok, i see. Seems its my fault after all then.

On the WAN page i disabled all checkboxes in the "Mode" (i think that is what it was called) column to remedy the message regarding the bridge mode not being available due to multi wan enabled.
I couldn't find (correct) info in the manual. Is this checkbox (second column) the same as in the online manual? (it looks differently in my WebUI)

I will have to check in the evening when i am back home and report back. But i guess that explains my issue.

by

It should look the same as in the manual, except the picture in the manual says "Back WAN" in the second column, while in new firmwares it's called "WAN Failover", so the picture is outdated.

Anyway, this is how you should set it:

by
as assumed this got it fixed. Thank you for the quick help!

Although my WAN WebUI still looks different. I don't have a combobox in the header row, only a text labeled "Mode". (Actually "Modus" in german. Strangely only some parts are in german when the UI language is set to english in the settings)
by
I'm glad I was able to help.

I tried setting the language to German and I think I get the same thing as you. This is probably some bug, but everything should work fine if you're not using Failover/Load Balancing. I'm registering the bug so there should a fix in one of the next releases. Thanks for your input!