FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
193 views 6 comments
by anonymous
I have tried following tutorials and instructions for configuring VPN hub but am unable to reach Omron PLC via VPN at 192.168.250.1. Should LAN port on TRB245 be set to static IP in 192.168.250.x subnet? I have tried setting TRB245 to static IP of 192.168.250.100 with VPN route to 192.168.250.1 but cannot ping 192.168.250.1 or 192.168.250.100 via VPN. Is there a step by step tutorial showing how to configure VPN for destination IP different to standard IP of 192.168.1.1?

1 Answer

0 votes
by anonymous

Hello,

Indeed, the PLC and TRB245 should be in the same LAN subnet. For example, if the TRB245 has an IP address of 192.168.250.10, you can set the PLC with the following configuration: IP address 192.168.250.1, subnet mask 255.255.255.0, and default gateway 192.168.250.10 (which is the LAN IP of the TRB245).

Please perform the following checks:

  • Ensure that LAN forwarding is enabled in RMS VPN Hubs -> Routes.
  • Verify that the default gateway is correctly configured on the PLC and pointing to the LAN IP address of the TRB245.
  • Check if you can ping the PLC from the TRB245. You can perform this ping test from the WebUI by going to System -> Administration -> Troubleshoot and scrolling down to diagnostics section. Put the IP address of the PLC.
  • In RMS VPN Hubs -> Routes, try adding a manual route with the following details: Destination network 192.168.250.0, subnet mask 255.255.255.0, and choose TRB245 as the client.

Please, let me know about the results and we can continue troubleshooting further if needed.

Kind Regards,

Andzej

by anonymous

I have configured TRB245 and VPN as per instructions and can ping PLC at 192.168.250.1 from Diagnostics of TRB245. I am accessing TRB245 by remote webpage through RMS.

From my PC, I have started Teltonika RMS VPN but do not have no response to pinging 192.168.250.10 or 192.168.250.1. Please see attached screen shot of Teltonika RMS VPN.

by anonymous

Hello,

I assume Stockton is the TRB245?

Recently, a new update for the RMS VPN client was released. Have you downloaded and installed the updated client yet? You should see a notification on the VPN Hubs page. This notification will include a link that you can click to download an update.

Also, can you try using OpenVPN Connect to see if it works then? You can download .ovpn config file from VPN HUB -> Clients page. There should be a download icon next to your email/user in the list. Upload this file to OpenVPN Connect.

If this does not work, can you check the routes on your PC? If you are using a Windows machine, you can execute 'route print -4' in the command line.

A troubleshoot file from the TRB245 would also be great. You can download a troubleshoot file from System -> Administration -> Troubleshoot. You can attach the file by editing your question. The attached files are only visible to Teltonika moderators.

Kind Regards,

Andzej

by anonymous
Further information before I try suggestions:

Ping from TRB245 can reach 192.168.250.1 and 192.168.250.10. Ping from local machine can reach 192.168.250.10 but not 192.168.250.1.
by anonymous

Hi,

In case you can ping TRB245, but not the PLC, that might be a routing issue.

Could you try accessing the WebUI of TRB245 and navigating to Network -> Firewall -> General settings? Try enabling masquerading for LAN => WAN zone and see if you can ping the PLC then.

Kind Regards,

by anonymous

Enabling masquerading for LAN => WAN zone solved my problem! Thank you!

Anytime I get involved in networking, is feels a bit like launching a rocket to far reaches of solar system where to be successful, all planets and stars must be absolutely perfectly aligned!

by anonymous
Hi,

Glad to hear that it works now. Sometimes it can get tricky indeed.

Thanks for letting me know that it works now.

Have a nice day!

Kind Regards,