FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
463 views 8 comments
by anonymous
Hello, is it possible to roll back the modem firmware version on RUTX50. My SIM card connection (Vodafone) was fine before I updated to the latest firmware. Now I am unable to get an internet connection. I am a very basic user and everything worked out of the box before the update. Does anyone have a simple solution?

EDIT: I have included the troubleshoot file in the post.

2 Answers

0 votes
by anonymous
The reply from Quectel: The new firmware version cannot be downgraded to previous versions, otherwise the module will not be able to work normally.
by anonymous
Do you have an advice on how to make my SIM connection working again given the situation?
0 votes
by anonymous

Hello,

  

I will ask you to perform a few troubleshooting steps:

  • In the Network → Mobile menu try disabling VoLTE;
  • Try disabling 5G in the same menu;
  • Try using a custom APN. This can be done by navigating to Network → Interfaces → General → edit the mob1s1a1 interface → Disable Auto APN and in the custom APN field enter internet;

If none of these steps help, I will also ask you to try and factory reset the device.

Perhaps you could expand a little more on what sort of issues are you facing? Perhaps it's related to DNS? What is the behavior of the LEDs on the router?

  

Best regards,
DaumantasG

by anonymous

Followed all steps provided with no success. The LED indicates no issues. Static green light on both SIM1 and 4G. Everything appears normal. However, when I try the built-in speedtest it says "Failed to retrieve provider IP address. Please check your internet connection."

Before I updated to the latest internal modem firmware SIM 5g connection worked out of the box with no tinkering. 

by anonymous
Hello,

 

This is a known issue with the Speedtest package, and it will be addressed in a later update. Please try running the speed test from your mobile phone or any other LAN device. The speed test package uses the approximate location based on the IP address, so it could be that the IP address changed after the update, and a different speed test server was chosen.

Alternatively, you could select a different server from the list manually.

  

Best regards,
DaumantasG
by anonymous
Tried connecting to the internet via my phone and PC. But on all devices I can only connect to the wifi with no internet connection. Internet both wired or wirelessly just does not work on SIM, though the SIM card is connected to the modem and registered. The SIM card itself works just fine in my phone and other lte enabled devices.
by anonymous

Hello,

  

Just to clarify, did the factory reset not help either?

The only message raising some concern in the logs is:

dnsmasq: found already running DHCP-server on interface 'br-lan' refusing to start

Which could indicate an issue with the router configuration or any LAN device running a DHCP server. If it's the first option, a factory reset should solve it.

  

Best regards,
DaumantasG

by anonymous
So I unplugged every LAN cable, left only SIM card, factory reset the device and SIM connection is now working just fine. I wanted to use my existing backup connection on WAN port but that seems to have caused the issue. The failover mechanism is weird. I set my wan connection as a second option in failover rules, to check whether the removal of SIM card would switch to this internet. And it did. However, after inserting the SIM card again I waited for 5 minutes and my pc was still on my backup connection, whereas my phone was connected to the SIM connection. Which I find odd. Nevertheless, the main issue has been solved so thank you for the input.
by anonymous

Hello,

 

The issue you were facing with failover is most likely because you have not enabled the Flash connection option. This is disabled by default, as to ensure as smooth a transition as possible, as the router will not cut the existing connections on failover, and will only rote the new ones thru the interface with the higher priority.

So as mentioned, to avoid this, navigate to the Failover menu, edit both of the interfaces that you have enabled, and to the option "Flash connections on" add Connected and Disconnected.

  

Best regards,
DaumantasG

by anonymous
Thank you for your cooperation. Will definitely try :).