FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
399 views 11 comments
by anonymous
Hi there,

I've upgraded the firmware on my RUTX12 recently to the latest version - RUTX_R_00.07.04.3. After that, I noticed that one of the SIM cards was not connecting to any of the three mobile networks available here. I tried it in both auto mode and selecting a network manually. I pulled the SIM card and inserted it into my phone to make sure that it was working, and it worked. I put it back and rebooted the device - no luck.

Then I decided to try swapping SIM cards. I have two of them, and the second was working. So I put the SIM card from the second modem into the first slot and vice versa. After that, neither of the modems were able to connect. I tried to reboot the device, swapped SIM cards back, and rebooted again, and nothing helped - both modems now can't connect. I'm attaching the "troubleshooting file" from the admin interface; hopefully, it could be helpful.

I'd appreciate any advice on how to fix this.

Thanks,

Denis
by anonymous
(I accidentally posted my comment in wrong place, moved it below)

1 Answer

0 votes
by anonymous

Hello,

  

It seems like the issue with both of the SIM cards could be an incorrect APN chosen.

APN can be set manually by navigating to Network → Interfaces → General → editing the mob1s1a1 and mob2a1s1 interfaces (for both SIMs). Disable the Auto APN option, and in the Custom APN field enter the APN used by your operator. For example, Vodafone CZ provides the correct APN settings here. For the other SIM, I would recommend looking around the carrier's website or contacting them directly. At least in the Vodafone case, no authentication is needed.

If this does not help, please replicate the issue and generate another troubleshoot file.

  

Best regards,
DaumantasG

by anonymous
Thank you, Daumantas,

I've tried to apply your advice and got the secondary modem working with a manually set APN and manually selected network. The primary modem isn't working at all, though, after many experiments.

--------

What I did, step-by-step:

- first, in the morning I discovered that both modems were stuck. There were lots of "modem unresponsive" messages in the logs, so I tried to reboot the device. Soft reboot (via the Web UI) didn't seem to help - the secondary modem came to life, but the primary didn't. So I tried a hard reboot - unplugged the power cord, waited for a while, and plugged it back. Now primary modem has also started flashing its LEDs like it should;

- I tried setting APN manually as you recommended. It didn't help either of the modems to connect in "Auto" mode, despite APN settings being the same for two operators in this area (O2.cz and Vodafone.cz);

- then I tried to do a manual network search, and the secondary modem connected to O2 - hooray, some progress!

- the first modem was still unable to connect, though, even when I manually tried to select O2 or Vodafone networks. I noticed that both LEDs were blinking, indicating something was wrong. I tried to click the "Restart connection" button on the Status > Network > Mobile tab for the first modem and observed the "Modem not ready" error message;

- I tried to SSH to the device and execute the "mctl -r -m modem" command, which seemed to help with the "Modem not ready" message, I can now "Restart connection," and it doesn't throw an error. The modem wasn't connecting, though;

- I adjusted the APN setting for the primary modem for the third operator available in this area (T-mobile.cz) and tried manually connecting to it. The modem didn't connect and was blinking two LEDs all of the time, so I tried a hard reboot again. No luck; nothing changed after the reboot;

- so I tried to swap the SIM cards. I pulled the SIM card from the secondary modem and inserted it in the first slot, leaving the second slot empty for now. The modem tried connecting for a while and then started blinking both LEDs again. When I selected Network > Mobile > Mobile operators tab, I saw an error message saying, "The modem is busy, connecting to operator". It can perform operators scan, though. I set APN settings for O2.cz (which was working for this SIM card in the secondary modem) and tried selecting O2 manually. It was trying to connect for a while and then started blinking both LEDs again, so I did a hard reboot again. No luck; it still can't connect. I think I waited long enough - for 15+ minutes.

- then I was wondering if I could get the first SIM card working in the second slot. I can't. The APN settings were set for O2 / Vodafone, and it couldn't connect to either. Previously, I checked this SIM card on my phone, and it successfully connected to Vodafone.

-------

Bottom line: I have two SIM cards and two modems, and the only combination that works is SIM card #2 inserted into the secondary modem, with manual APN settings and manual network selection. All other combinations don't work, even including the only working SIM card in the other slot with the same settings.

Could you please advise on how to proceed? I've attached another troubleshooting file to the original question.

Thanks,

Denis
by anonymous

Thank you for the detailed write-up!

The behavior does sound strange. Perhaps you could try resetting the device using the bootloader procedure? Interestingly, when the issue is on the carrier side, the modem still connects to any cell from a different operator for emergency calls, however, in this case, neither of the modems is connected to a cell at all, and neither can it find any nearby. This would suggest to me that there is an issue with the signal. Please double-check if all of the antennas are screwed in and tightened properly.

I will also ask you to generate another troubleshoot file once the device connects to any of the carriers (either O2 or Vodafone).

If these steps do not help, we might need to try and update the modems. Contact me via private message if that's the case.

  

Best regards,
DaumantasG

by anonymous

Thank you, Daumantas,

I reset the device using the bootloader procedure with the same firmware version that was already installed (RUTX_R_00.07.04.3), and... all my settings are gone :) Well, I suppose this is what reset should be doing. Anyway, I did a minimal setup - configured the admin password, wi-fi, added my SSH key, and set the secondary modem as the primary network interface to access the internet. Other than that, I haven't changed anything. 

The current state is:

- the secondary modem has successfully connected to O2, being in the "Auto" network selection mode and with the "Auto APN" setting turned on (everything by default);

- the primary modem doesn't connect, and all its LED lights are off.

Please see the latest troubleshooting file attached to the original question.

Thanks,

Denis

by anonymous
Hello,

  

The only thing visible from the logs is that the first modem is trying to connect to the operator, but is unsuccessful.

One thing I did notice, is that the second SIM is roaming, and judging by its IMSI, I presume you are in Poland at the moment. Are you sure the SIM card allows roaming? Or perhaps you are in the border region?

  

Best regards,
DaumantasG
by anonymous

Hi Daumantas,

I'm currently in Czechia, and both SIM cards are in roaming, and they both allow roaming. I have tested the SIM card that can't connect in my phone, and it worked well. And even more, a couple of weeks ago, the same SIM card worked successfully in the modem when I was in Poland, where it also was in roaming. 

So to summarize, I have a SIM card that:

  • doesn't work in the modem;
  • at the same time, it works in my phone;
  • it worked in the modem when I was in Poland (while also being in roaming).

Thanks,

Denis

by anonymous
I'll contact you via a private message.
by anonymous
Alright, the saga continues. Now I've moved to Germany with the same SIM cards. Both modems were unable to connect in the "Auto" network selection mode. I tried to "Restart connection" or hard reboot the device - no luck. I tried to manually select each of the three available operators in this area - Telekom, O2, and Vodafone. No luck for both modems.

Then I tried pulling the second SIM card from the device and using them on my phone to check that it could connect. I haven't checked all of three operators, but it has successfully connected to Vodafone in the "Auto" mode. Once the SIM card had been connected, I got an SMS message saying that the data package on this SIM card was exhausted. I refilled the balance, added another data package, put it back into the device, and tried selecting Vodafone manually. Now, after a long waiting (much longer than on the phone), it has connected, finally.

I tried the same trick with the first SIM card, but it didn't work. I've put the first SIM card into my phone, and it has quickly connected to Telekom. Then I put it back into the device and tried to select Telekom manually, and it didn't work. Even more - the second modem has also disconnected! After a minute or two, it connected back. WTF Teltonika, this is so frustrating.

Please see the Troubleshooting file attached to the original message.

P.S. I'm using the RUTX_T_H744_00.07.04.112 firmware version Daumantas has recommended using in the private messages.

Thanks,

Denis
by anonymous
Hello,

One clarification I would like to make - the APN used must be from your home country operator. This information is not available in the troubleshoot file, but let's say your operator is Telekom.de in Germany. If you are roaming in Spain, you will still need to use the APN from your original operator, not the local operators.

Could you clarify the actual operators of these SIM cards?
by anonymous
I haven't set APN manually, it's in the "Auto" mode for both SIM cards. The SIM card operators are:

SIM #1 - KCell (Kazakhstan)

SIM #2 - Play (Poland)

Thanks,

Denis
by anonymous

Hello,

    

Both of these operators use APN internet, so please navigate to Network → Interfaces → General, edit the mob1s1a1 interface, disable the auto APN, and in the Custom APN field enter internet. Do the same for mob2s1a1.

KCell APN settings: https://b2b.kcell.kz/en/article/for-smartphone-owners

Play APN settings: https://www.play.pl/nowy/pomoc/naprawa-i-konfiguracja/konfiguracja-telefonu

This is just to ensure the correct settings are used.

It also looks like the option Deny data roaming is enabled in the Network → Mobile → General. Make sure to disable it on both SIM cards!

Then disable the manual operator selection (leave on Auto), and regenerate a troubleshoot file if you are still experiencing issues.

  

Best regards,
DaumantasG