FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
251 views 6 comments
by anonymous

Hi guys,

I have a problem regarding STP and OSPF in this Teltonika setup that I simulated with Cisco Packet Tracer. The idea is to create a network that is n-1 redundant. Unfortunately, this is the first time I'm setting up such a complicated network, and there is a high possibility of me missing something.

Here is my setup:

RUTX09:

  • DHCP Server
  • WAN will be used later
  • eth0 bridged
  • STP enabled

Switch1:

  • RUT300
  • DHCP Relay
  • WAN as LAN
  • eth1, eth0.1 bridged
  • STP enabled

Switch2:

  • RUT300
  • DHCP Relay
  • WAN as LAN
  • eth1, eth0.1 bridged
  • STP enabled

Switch3:

  • RUT300
  • DHCP Relay
  • WAN as LAN
  • eth1, eth0.1 bridged
  • STP enabled

Whenever I close the loop in one place, I experience a network storm, and none of the devices are responding, despite having enabled STP on every device. Interestingly, I can access the WebUI only if I connect to one of the WAN interfaces, but only the one I am plugged into.

When the loop is open, OSPF is working as intended and establishing its neighbors and routes.

What am I missing in my routers configurations? Do you need more information?

Thank you in advance!

1 Answer

0 votes
by anonymous
Hello,

You're doing nothing wrong it seems.

After some internal testing I can say that there seems to be an issue with STP working with the routers at the moment. I am consulting our RnD at this moment to see if maybe we're both doing something wrong on is the a legitimate issue
by anonymous
Hi,

thank you for looking into that. Please keep me posted, can't wait to get this up and running.

Have a great day!
by anonymous

Okay, I've looked at the individual packages with wireshark and it does seem like the message age is not increased in any message. Furthermore, with IEEE 802.1d the max recommended distance is not more than 7 hops, how do we get a max age of 10 here?

by anonymous
Hello,

are there any updates on this topic? My setup is running with a work around right now, but we will need STP for our use case and I'd like to have this issue resolved by the end of this month.

I appreciate your quick response.
by anonymous
Hi,

I still have not received an answer from our RnD
by anonymous

Hello,

There is an issue on the current firmware where not all the settings are applied to the config when enabling it. We will fix that with a future firmware release, currently these is a quick fix you can do:

Using CLI you need to set stp option to 1 on a specific interface bridge. For example, for LAN interface it would be uci set network.br_lan.stp=1 then uci commit network and reload network with /etc/init.d/network reload command.

To check if STP is enabled, you can use brctl show br-lan command. In this case br-lan is LAN interface's bridge device name.

by anonymous

Hi,

thank you very much for the update! Your suggestions however are unfortunately not working for me.

I made sure to have the most recent firmware and set the bridge on every router to have stp = 1 and made sure it is enabled with the "brctl show" command. See the attached pictures. Other than that completely reset the routers and did not enable OSPF this time, to simplify the problem (VRRP is still enabled).

Furthermore I attached a wireshark file for you to understand the problem and maybe find the culprit in this issue. NetworkTrafic It shows a working network without a loop, then a quick connecting and disconnecting of the loop, before the network starts to work normal again.

I also attached the overview of my network setup with ips and the outputs of "uci show network" UCIShowNetwork for a clearer picture.

If you need anything else I can help you with, please feel free to ask.

I look forward to your reply.