FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
388 views 1 comments
by anonymous

Device name RUT240

Product code RUT24006XXXX

Serial number 1112582762

Hardware revision 0010

Batch number 0095

Firmware version RUT2_R_00.07.02

Kernel version 5.4.147

I tried to update the firmware to 00.07.04.3, as I want to install the ZeroTier package, which doesn't seem to be available in firmware 00.07.02.

When using FOTA for the update nothing happened, although the server said that 00.07.04.3 was available.

I then downloaded "RUT2_R_00.07.04.3_WEBUI.bin" and made a manual update from file, which seemed to be successful, but after rebooting RUT240 still reports, that it is version 00.07.02 and now the server says, that there is no update available.

How can i update to the latest firmware?

1 Answer

+2 votes
by anonymous

Hello,

Please be aware to disable the "Keep settings" option if you attempt to upgrade the firmware manually from a file.

If it is still not working, you may upgrade the firmware using the SSH software / CLI as shown below:

---------------------------------------------------------------------------------------------------------------------------------------------------

Upload RUTXXX_R_00.0x.xxx_WEBUI.bin file to the router. You can do this with WinSCP software:

File protocol: SCP

Host name: 192.168.1.1 (router IP address)

User name: root

Password: admin01 (or new WebUi password)

Copy the file RUTXXX_R_00.0x.xxx_WEBUI.bin to /tmp directory.

Connect to RUT by SSH. User: root. Password: admin01 (or new WebUi password)

Under Linux:

ssh root@192.168.1.1

Under Windows:

Best use Putty software or something similar:

http://www.chiark.greenend.org.uk/~sgtatham/putty/

Enter these commands:

root@Teltonika:~# cd /tmp/

root@Teltonika:/tmp# sysupgrade -n RUTXXX_R_00.0x.xxx_WEBUI.bin

Wait about 10 minutes, while firmware will be upgraded.

---------------------------------------------------------------------------------------------------------------------------------------------------

Best Regards,

Best answer
by anonymous
Thank you, will try that.

I did check the "Keep settings" when updating from file. I didn't know, that this could make a difference, when the option is there.

The unit is 400 km away and I only have access to it through a VPN tunnel. I need to wait until I am physically at the unit then before trying again.