FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
89 views 1 comments
by anonymous

Hello, I am trying to configure a TRB140 via SSH commands but it does not look like the command is doing what it should be doing. 

First I use the SSH command "uci set simcard.@sim[0].auto_apn='0'",  to disable auto apn, then set a custom apn and finally I use "uci commit" and it looks like it is accepting it. 

However, when logging on to the router webpage auto apn is still enabled for the mobile network. I checked the status of the simcard with "uci show simcard" and the attached image is how it looks. 

Why are the two settings different? I tried rebooting the router and then I lost my custom APN, so it looks like the webpage auto apn setting is the "real" one.

1 Answer

+1 vote
by anonymous

Hello,

  

Auto APN settings are stored in the network configuration file, rather than the simcard.

To change this value, use these commands:

uci set network.mob1s1a1.auto_apn='0'

uci set network.mob1s1a1.apn='<inser_your_APN>'

Make sure to also change the PDP type and auth settings if needed.

  

Best regards,
DaumantasG

Best answer
by anonymous
Thank you for such a quick reply! That explains it and solves my issue :)