FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
349 views 1 comments
by anonymous
Hello,

I'm using the RUTX50 with latest firmware with german Telekom business with the option static IPv6.

I want to access the router from outside with a static IPv6 on mobile interface. I use the APN festeip.telekom.

I can already access the router from outside via IPv6 and login via webinterface.

The problem I have is the following: The prefix is fix (first 64 bit), but the router uses another suffix with every reboot.

From Telekom side it looks good, in an Android device the static IPv6 is working, prefix and suffix are the same after reboot. So I suppose the problem is with the RUTX50.

On Telekom webpage is stated, that the device need support the feature "64share" (seems RFC 7278).

https://geschaeftskunden.telekom.de/mobilfunk/tarife/zubuchoptionen/erreichbarkeit/feste-ip-v6-adresse-flyer

Is this supported from RUTX50?

If yes, how can I configure it?

Thanks,

Bernhard

1 Answer

0 votes
by anonymous
Hi,

I am not aware of it myself, I have asked our RnD team to input a bit on knowledge here to see if we are missing it or is there something else
by anonymous

Make sure that PDP type is set to IPv6 on the mobile interface used. This should be done in interface settings

Go to CLI and set dhcpv6 to 1 on that interface with these commands:

  1. uci set network.mob1s1a1.dhcpv6=1
  2. uci commit network

At the end restart network with /etc/init.d/network restart.