FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12678 questions

15063 answers

24130 comments

47080 members

0 votes
933 views 2 comments
by
Hello,

Is there an option to get the wireless hotspot in the same IP Range as the LAN conection? i know i can set the LAN IPs quite freely but on the wireless side i can only set the AP IP on the hotspot options. For example LAN and Hotspot should be 192.168.1.xxx with the same subnet. everything i tried locked up the hotspot somehow. maybe i am missing something obious i hope.

Here is the full situation:

i want to setup an hotspot on a RUT955 which can reach devices which are connected by LAN without any barriers, like the hotspot devices are on the LAN or a normal WLAN. The LAN devices are an Synology Diskstation NAS DS215j and a Loxone Miniserver for Home Automation. The Problem is i can't reach the devices with full functionality from the hotspot, for example no conections when using the provided apps from Synology and Loxone on mobile devices. When opening the ports i can access the WebUIs over the browser, but mainly the DLNA/UPnP i cant get to work. I have to admit that I'm not at all an expert in managing ports. I have read that DLNA works only in the same IP range, so thats the reason why i want to solve the issue with the same ip range to get a reliable system.

Thanks so much in advance, please ask if you need more information, Cheers

Michael

1 Answer

0 votes
by

Hello Michael,

Try changing the firewall settings as in the picture and let me know if it works (Default Forwarding Action to Accept for Hotspot). By default router drops the connection from LAN to hotspot and vice versa for security reasons.

/Danius

by
Thanks for your quick reply and sorry for my late response, i had to wait to get my hands back on the router.

This firewall setting helps - i can connect to the devices over the IPs fine, but the devices still don't show up in the apps (DLNA/UPNP protocol). There seems to be still a barrier in the way or the apps only check in the same ip range as the are in (hotspot devices at 192.168.2.x cant find devices in the LAN at 192.168.1.x)?

Do you have more ideas?

Thank You,

Michael
by

Hello, Michael

It seems like a routing issue. Your end device doesn't know how to reach DLNA server or vice versa. Could you try configuring static routes on the system you are using?

For example (Windows):

route ADD dlna_servers_network MASK subnet_mask gateway_ip(hotspot)
route ADD 192.168.1.0 255.255.255.0 192.168.2.1

This way if you try reaching 192.168.1.0 network, routing table will guide the packet through 192.168.2.1

Try it and let me know how it went. Good luck.