FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
584 views 0 comments
by anonymous
Hi,

When I enable remote SSH access and leave port 22 under Access Control - I keep getting an error message in Putty (Server's host key is invalid) and remote CLI on the fails too.

When I change the port to 2222 SSH works and remote CLI works too.

Kind regards,

Tom

1 Answer

0 votes
by anonymous

Hello,

  

Yes, remote access is still possible, however, for increased security SSH RSA keys are no longer supported, and only the ECDSA keys will be generated moving forward.

This is mentioned in the changelogs as:

RUTX_R_00.07.04.3 | 2023.05.11

    • Improvement
      • System
        • Removed SSH RSA key generation
        • Added SSH ECDSA key generation
        

    In order to connect to the device using PuTTY, you will need to delete them from the registry, as that is where they are stored. A tutorial on how to delete them can be found here.

    It works when you change to port 2222 because the PuTTY session to this device on this port has not been established before, thus ECDSA keys are generated.

    Hope this helps!

      

    Best regards,
    DaumantasG