FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
3,357 views 3 comments
by

I have a RUT240 and I am trying to set it up as a VPN client (L2TP/IPSec) to my router (Ubiquiti Security Gateway) at home. The IPSec connection is successfully established but the L2TP connection fails. The log in the USG says "pppd[22894]: Connection terminated: no multilink.". If I connect my phone to the same VPN it works, even through the Wifi of the RUT240. I have tried to find any logs on the RUT240 but failed.

If I use PPTP it works.

3 Answers

0 votes
by
It is working now. Apparently I had to enable mschap-v2 on the server side. When I tried to connect a Windows client I got an error message indicating just that. It worked on an iOS device without though.
Best answer
0 votes
by anonymous
Hi,

Have you tried according details here?: https://wiki.teltonika.lt/view/L2TP_over_IPsec
by
Yes, i have followed that guide (the client part). The IPSec connection seems to work but the L2TP connection fails with the error mentioned above.
by anonymous
Hi,

Which FW release router use?

Could you add screenshot with settings from router and cell phone where it works correctly? Private information can be removed.
by
The settings in IPsec and L2TP on the RUT240 is exactly as in the guide, apart from ip numbers, username and password. The phone is in swedish so I don't think it is any help, but I have chosen L2TP and entered server ip, psk, user and password and it works perfectly.

I am using the latest firmware, RUT2XX_R_00.01.07.1.

The router is behind CGNAT (private ip) if that makes any difference (should not, because so is my phone).

Is there any PPTP/L2TP logs on the router? Can I initiate the connection via CLI to be able to debug?
0 votes
by

This is the full content of the log from the server:

Jun 18 02:19:34 Gateway xl2tpd[21311]: Connection established to 94.191.133.95, 1701.  Local: 41889, Remote: 53419 (ref=0/0).  LNS session is 'default'

Jun 18 02:19:34 Gateway xl2tpd[21311]: Call established with 94.191.133.95, PID: 21907, Local: 11861, Remote: 48056, Serial: 3

Jun 18 02:19:34 Gateway pppd[21907]: pppd 2.4.4 started by root, uid 0

Jun 18 02:19:34 Gateway zebra[679]: interface ppp0 index 5036 <POINTOPOINT,NOARP,MULTICAST> added.

Jun 18 02:19:34 Gateway pppd[21907]: Connect: ppp0 <--> 

Jun 18 02:19:40 Gateway pppd[21907]: Connection terminated: no multilink.

Jun 18 02:19:40 Gateway zebra[679]: interface ppp0 index 5036 deleted.

Jun 18 02:19:40 Gateway pppd[21907]: Modem hangup