5747 questions

6967 answers

11236 comments

7061 members

0 votes
1,052 views 5 comments
by

Hi,

I've got some issues when trying to use a RUT955 (latest software) as a terminal server to connect to the console port on a Cisco device. I've followed the guide(https://wiki.teltonika.lt/view/Reaching_Cisco_router_console_port_remotely). 

But when connecting using the physical RS232 port I get no response at all form the Cisco device. (Using a RS232 gender changer and a standard light-blue Cisco RS232 to RJ45 cable). Could be a cable error...

When trying the USB option I'm able to connect but when trying to do a show running-configuration the output is cut short (tried both putty and SecurtCRT). Are there any additional settings?

Regards

Daniel

4 Answers

0 votes
by
Hi,

Have you tried with another cable? Baud rate is selected correctly?

Also you could try to reach it directly from router SSH, use command: microcom /dev/ttyUSB0
by
Hi,

Thanks for your answer.

Yes, tried with another cable (cisco and non-cisco USB cable), same issue. I was not able to connect using your command above. But I was able to connect using:

microcom /dev/ttyACM1

Which got when looking at the processes running while I was connected over a IP connection to the RUT device.

Alas I have issues still, it seems to loose packets/characters when doing a show run.

Regards Daniel
by
Perhaps there is some restriction in cisco or in used software.

Try with other software's.
by
I have tried without luck connecting to the Cisco serial port either.  I would try USB but I don't have any USB settings under Services.  Also, in your example you show 2 stop bits, the Cisco by default is 8,N,1 (1 stop bit) and your picture of the Cisco console port has the AUX port identified.

I have the cable LFHUKEJI (RJ45 to RS232) and verified the pins are correct.

I get characters echoed but nothing from the Cisco.  I also tried the microcom method also without any luck.
0 votes
by
Hi,

Teltonika RS232 port acts as DCE device and cisco console DCE as well.

Gender changer not change pinouts, just makes from hole pin i.e. hole#1 goes to pin#1, etc.

For connecting DCE to DCE you need to use null modem cable which can be bought or home maded - jut swap wires in pins 2 and 3 on DB9, or pins 3 and 6 on RJ45 connector.

The easiest way is cut RJ45 connector, crimp new one turned upside - down, this will swap pins 3 and 6, but 4 and 5 as well but this should be fine because these are both GND and interconnected in router socket I think. Rest wires are not used in communication and can be cut off.

Regards

Jiri S.
0 votes
by
hey guys,

did you get it working finally with the cisco console port?
0 votes
by

hey guys,

did you get it working finally with the cisco console port?

by
Hi,

No I didn't solve the issue, I had the same issue using both a null-modem cable and a USB cable.

Regards
by
i tried it with the trb142 - that worked somwhow

i connected the pins 1 to 1 - so no cross over or so