subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
4,716 views 14 comments
We have a VoIP phone connected to an RUT950. The phone intermittently has one way audio problems. A health check on the VoIP system showed SIP ALG as being enabled. We have since turned on the RUT950 SIP helpers and opened a port forward for the required phone ports. The health check still showed SIP ALG enabled. Does this need to be turned off elsewhere?
Update: We have been told that there is a possibility the EE 4G mast has SIP ALG enabled and that this might be causing the issue. The intermittent one way audio still occurs despite port forwarding and SIP helpers being enabled.

Update 2: Following many other checks, we disabled SIP Helpers and the Health check on the VoIP system showed SIP ALG disabled! However on testing the VoIP phone, the call problems were even worse! Calls not connecting, one way audio when a call did connect etc.

Is there any way to disable SIP ALG in the command line?
by anonymous


You can remove sip helper package by using this command:

opkg remove kmod-nf-nathelper-sip

If that doesn't work try removing kmod-nf-nathelper-extra package

opkg remove kmod-nf-nathelper-extra

You can also remove h323 helper package using this command:

opkg remove kmod-nf-nathelper-h323

After that reboot the router and try again.

Could you also generate and send me your troubleshoot file and backup via Private message?

Troubleshoot: System > Administration > Troubleshoot

Backup: System > Administration > Backup

Hi Dave

Just wondering if you managed to resolve this issue as we have a client with the same problem?

Many thanks

Hi Paul,

Unfortunately the only solution we found in the end was to switch networks to Vodafone. We also disabled the SIP Helpers which seemed to help, ironically!

We have set up a number of these devices on EE at other sites and they seem to work OK, it seems like it might be something peculiar to the mast we were connected to at that location.

We have also encountered SIP-ALG type issues when the VoIP phone was being called directly, but oddly enough when the calls were redirected to the phone's extension from a 'hunt group' it worked fine. No idea why that makes a difference, but as a workaround it seems to function OK.

I hope you can get it sorted!

2 Answers

0 votes
by anonymous
Hello Dave,

Have you tried same setup with some other router? Was it working before?
Hi, thanks for the comment, no this is a new installation. I haven't tested it with any other teltonika router. The VoIP phone was previously working on a fixed broadband line however.
by anonymous
Could you draw up the topology of your setup? And also could you tell me the model of VoIP device?
by anonymous
Could you also provide a model of your voip device?
Ah yes sorry. It is a Polycom VVX 411 I think.
by anonymous
"The phone intermittently has one way audio problems" - Could you please describe this in more detail? You can't receive calls but can make them or vice versa?

Did you consult with your phone service provider on how to configure your phone?
From what I have been told (I have not experienced it personally), on incoming calls, the caller can hear the person at our end, but we cannot hear them. We can make calls via our internal VoIP with success it seems, but external calls are a problem.

Our VoIP provider ran a health check and they say that the SIP ALG is showing up as enabled. They also gave me a couple of ports to open, which I have created port forwarding rules for. I have also enabled the SIP helper on the router. The health check still shows SIP ALG as enabled. The phone itself should be configured correctly, as our VoIP provider configured this for us.
Please see the updates to the question for more info.

Thanks for your help. The CLI commands didn't help unfortunately, we still have only one way audio.

I am not sure about sending a troubleshooting file for security reasons. Is there anything particularly that we would need to look for in it?
0 votes
by anonymous
Thanks Dave

That's really useful!

Take care

by anonymous

we are experiencing similar problems: same phone, with a RUT955 on Vodafone. Any solutions found? Out of interest, everything was working just fine for a couple of months, and this has suddenly started.