4792 questions

5860 answers

9403 comments

5726 members

0 votes
1,580 views 5 comments
by

Hello all,

After upgrading the firmware of a RUT230 from v00.00.348 to v01.03.02 the overview screen remains empty. 
The page System > administration > Overview creates an error message:

/usr/lib/lua/luci/dispatcher.lua:518: Failed to execute cbi dispatcher target for entry '/admin/system/admin/overview'.
The called action terminated with an exception:
...b/lua/luci/model/cbi/admin_system/overview_setup.lua:95: attempt to concatenate global 'real_name' (a nil value)
stack traceback:
 [C]: in function 'assert'
 /usr/lib/lua/luci/dispatcher.lua:518: in function 'dispatch'
 /usr/lib/lua/luci/dispatcher.lua:263: in function </usr/lib/lua/luci/dispatcher.lua:262>

Is this a known error, a firmware issue? Is there a way to fix this?

Best regards,
Bas

1 Answer

+1 vote
by
Hi,

This was not reported before. Is it possible for you to reset the router ? Also did this happened to only one device ?

If you don't need to save any settings you can upgrade FW via bootloader menu by following this instruction:

https://wiki.teltonika.lt/index.php?title=RUT2xx_Firmware_via_The_Bootloader_Menu

Does the same error remains after reboot ?
Best answer
by
A little update. Looks like there was a fix for this exact issue. Do you had OpenVPN configured previously ? It might be an old issue which was kept while upgrading Firmware and keeping settings.

Is it possible for you to upgrade without keeping settings once again ?
by

Hi,

It occurred on 1 device only, because there is no other RUT230 to update. I can reset the device, it is not in real operation at the moment, but prefer not to erase the configuration to often ;-).
I just found a similar error also in the page Status > Network > OpenVPN
 

/usr/lib/lua/luci/dispatcher.lua:518: Failed to execute template dispatcher target for entry '/admin/status/netinfo/openvpn'.
The called action terminated with an exception:
/usr/lib/lua/luci/template.lua:105: Failed to execute template 'admin_status/netinfo_openvpn'.
A runtime error occured: /usr/lib/lua/teltonika_lua_functions.lua:365: bad argument #1 to 'char' (integer expected, got nil)
stack traceback:
 [C]: in function 'assert'
 /usr/lib/lua/luci/dispatcher.lua:518: in function 'dispatch'
 /usr/lib/lua/luci/dispatcher.lua:263: in function </usr/lib/lua/luci/dispatcher.lua:262> 

I will first try to update the same firmware again, then downgrade to 01.02.3 to test. I will see if the described method makes any difference.
Any other suggestions are welcome  :-)

Best regards,
Bas

by
You don't really need to downgrade. You can just upgrade to the version RUT2XX_R_00.01.03.2 without keeping settings and this should be enough.
by

You could also try a manual fix if you want. This issue occurred because previously interface name was in ASCII format, latest FW uses HEX.

1. Login to router via SSH.

2. In command line write vi /etc/config/openvpn and press Enter.

3. Now you are in openvpn configuration file.

To enter edit mode press i and in lower left corner you should see I, which shows that you are now in edit mode.

With arrow keys navigate to line config openvpn ‘client_Next’  and change 'client_Next'  - example name to '636C69656E745F4E657874' - example name


Next go to line option persist_tun ‘1’ and with Enter add new line, which should contain this text: option name_is_hexed ‘1’.

4. To exit edit mode press Esc button on keyboard, write :wq (colon with wq) and press Enter.  If everything is alright, you should see primary SSH window with RutOS logo.

5. Now in command line write /etc/init.d/openvpn restart  and press Enter.

6. Next, write luci-reload and press Enter.

7. If everything was done correctly and no errors were shown, then Status → Network → OpenVPN window should work fine.

by

Somehow my last update was not saved, so for the record again:

Thanks Vilmantas1, for your quick and elaborate answers. I have updated again, without keeping the configuration, which in the end solved the issues.

Best regards,
Bas