10465 questions

12475 answers

19401 comments

21926 members

0 votes
1,154 views 6 comments
by

After the firmware update to the newest version:  On the I/O status page I can see the digital input switching when I short the pins, but none of the rules will be executed:

I have tried 'SMS sending', 'restart' and 'turn on/off WiFi' with no effect on both of the digital inputs with both of the two states and checked that the rule is enabled.

The firmware is the newest 00.06.04.3 - in the older version before (don't remember which one) all worked fine ...

by
Same here, digital input rule does not send sms after upgrade, is there a fix on the way?
by

Experience similar problem with Rut 955 firmware 00.06.05.3. Digital isolated input (2,7) works with Input rules "High level" but not with "Low level" Tested with SMS and relay output activation. Are there any software errors?

by
The suggested solution from Teltonika has worked: A hard reset to the default settings and a new configuration of the rules - seems that an update to a newer firmware mixed up the settings on a deeper level, invisible via the interface ...

However you will lose all settings (eg. altered IP adresses etc.) - if you have only remote access to the router, you will probably lose the access itself. So it seems a good idea to activate the RMS access via Teltonika before the reset: You have to create an account at Teltonika, then you activate the RMS management in the router settings, and finally you can add the router to the RMS, which is free of charge for one month - after this the access will be deactivated via RMS, if you don't want to pay for further access. But the great advantage of this solution is the possibility to maintain direct access to your router separate from all resetted settings, so that you can reconfigure it to your needs ...

1 Answer

0 votes
by
Hello, I made some tests on FW ver.: RUT9XX_R_00.06.04.3 and the Rules are working OK.

Can you show us more in depth what kind of rules you had setup?

How are you trying to reach the router? via Public IP, via SMS, etc to activate the rules?
Best answer
by

I am reaching the RUT955 via LTE mobile internet connection - the landing platform is a Windows10-PC with TeamViewer running, and I access the RUT955 from that PC with the latest version of the Chrome browser per internal network IP over the http-interface to view the status pages, configure / activate the rules, etc.

In the Service-section of the RUT955 I configure in the Input/Output-menu one Input-Rule for the Digital Input (pin 1+6):

Digital -- Input-shortened -- Send-SMS -- activate

The SMS-number has been tested with the SMS-Utilities -> SMS-Management -> Send-SMS-Tool with success, so that the router and the SIM can send SMS. On the Status-Page of the Input/Output-Section I can see the input status changing properly, but the action will not be triggered by the Input-shortened-rule: Nothing happens.

If I change the rule from the Digital-Input to the Digital-isolated-Input (pin 2+7): Same result; if I change the action of the rule from Send-SMS to Restart: Same result. No entry occurs in the event log, neither the changing input status nor the rule action.

Seems to me the same problem as in this post: https://community.teltonika-networks.com/8181/rut955-digital-input-wi-fi-on-off-not-working

by

Hello again.

We made some tests with different devices and it still works OK, We did set Wifi rule, Relay Rule and so on and the rules are working OK.

We can advice you any of the 2 following things

Restore to default settings

https://wiki.teltonika.lt/view/RUT955_Administration#General

Or upgrade and before the upgrade disable the Keep all settings. So the device can restore to default settings.

https://wiki.teltonika.lt/view/RUT955_Firmware

Then after that, you can go to establish all the rules you need

by
The suggested solution from Teltonika has worked: A hard reset to the default settings and a new configuration of the rules - seems that an update to a newer firmware mixed up the settings on a deeper level, invisible via the interface ... thanks a lot!