8400 questions

9885 answers

15679 comments

14155 members

0 votes
955 views 4 comments
by
When I use the RUT955 as the NTRIP router I get bad results, almost never recieve RTK Integer (level 6). My provider tells me that something is wrong with my configurations.

I tried with default NMEA and without, same results.

When I replace the RUT955 with a laptop with NTRIP client, with the same parameters, I recieve a much better results, RTK integer (level 6) most of the time.

What can be wrong?

Is it possible that the NTRIP data is re-written when it passes through the RUT955 ntrip mode?

1 Answer

0 votes
by
Hello,

Have you tried to enter Default NMEA string parameter? It's used as default value when initiating connection with NTRIP server and this can cause this error for you.

String has to look similar to this: $GPGGA,123519,5925.150,N,02443.300,E,1,08,0.9,0.0,M,0.0,M,,*73 and you can generate it in this site: https://nmeagen.org
by
Hi,

Thanks for your assistance,

Yes, I tried adding a default NMEA string, changing it and removing it but in any of these cases the result didn't change.

moreover, the default string should not be used when the NTRIP device is active.

how can I see/debug the NTRIP data that is passing through the router?
by

Hi,

You can try to login to router via SSH or CLI (https://wiki.teltonika.lt/view/RUT955_CLI) and cat /dev/rs485 or /dev/ttyATH0 and check what information are going through the port.

by

Hi,

Thanks for your help,

The "cat /dev/rs232" displayed the strings that came from the NTRIP device (OxTS RT3000):

$GPGGA,085226.00,3209.4143,N,03447.8417,E,5,16,0.8,15.10,M,19.10,M,01,0021*56

$GPGGA,085228.00,3209.4143,N,03447.8417,E,5,16,0.8,15.10,M,19.10,M,01,0021*58

$GPGGA,085230.00,3209.4143,N,03447.8417,E,5,17,0.8,15.11,M,19.10,M,01,0021*51

$GPGGA,085232.00,3209.4143,N,03447.8417,E,5,15,0.8,15.11,M,19.10,M,01,0021*51

It looks Ok, I verified the data at https://rl.se/gprmc

I also saved the output of the cat command to a file and imported it into https://nmeagen.org/

The data that was recevied seems ok, the point were displayed in the correct location.

so the communication with the NTRIP client via rs232 was verified and is OK.

That was the receiving side (from the NTRIP device), perhaps the transmitting side (to the internet service) has a problem, 

Is there a way to see/debug the traffic that is being sent to the mobile access point?

by

Hi,

You can try to use tcpdump function to collect packets from all or specific interface https://wiki.teltonika.lt/view/RUT955_Administration#TCP_dump. Then downloaded pcap file can be analyzed with WireShark (check payload and etc), otherwise you can use command tcpdump -i wwan0 dst port <ntrip_connection_port> this will show packets, but this only show traffic with payload.