10133 questions

12113 answers

18771 comments

20341 members

0 votes
4,240 views 7 comments
by
Hi,

I have a RUT240 with FW ver.: RUT2XX_R_00.01.03.5. Using a prepaid SIM, operator Tre (Three) in Sweden, works fine. But when using a contract SIM from the same operator AND with additional service "static IP" it fails. After a lot of "trial end error" I got it to work: added "option proto 'dhcp'" in /etc/config/network section "interface 'wan'" and changing "option proto 'qmi2'" to "option proto 'wwan'" in /etc/config/network section "interface 'wan'" and /etc/config/simcard section "sim1 'sim1'". (I also removed "option profile '238'" from /etc/config/simcard section "sim1 'sim1'").

I actually don't have enough knowledge how to do this type of configuring, please tell me if it's correct or how it should be!

I propose you add testing of contract SIM cards from this operator (Tre, in Sweden) both with additional service "static IP" and without that service. Also, add it to your mobile setup wizard (APN "bredband.tre.se" for no static IP and APN "static.tre.se" for static IP).

Regards

2 Answers

0 votes
by

Hello,

A fix regarding this issue has been released. You can download it from here.

Best answer
by

Hi,

Thanks. The link is though to a "RUT9XX" firmware file. Can I use it for upgrading my RUT240?

by
Sorry about that, didn't pay attention to the description this time. RUT2 FW will become available shortly. I'll reply here again.
by

Hi again,

The fix for RUT2xx can be downloaded from here.

by

Same problem here: do I have to install the fix file for rut955 you provided (RUT9XX_T_F0165_00.05.02.112_WEBUI) or can i install the latest firmware (RUT9XX_R_00.06.04.5)?

0 votes
by
Hello,

Is the SIM data only?
by

Hi Dziugas,

Yes, it is a data only SIM. I think you have two problems: 1) To get an IP address (option 'dhcp' in interface 'wan') and 2) To properly set APN (option proto 'wwan', i.e. automatically select QMI) to get a "static IP". See also the wiki question "Mobile data status disconnected".

It now works but I would appreciate a "verified" configuration...

by
Your configuration looks correct, I wouldn't worry about that. The issue is that the router doesn't do these actions automatically when a data only SIM card is inserted.

Thanks for this information, this will help testing and eventually preparing a fix. I'll try and respond to all related posts when there's news regarding this subject.
by
It does indeed seem to be an issue with data only SIMs

Using a RUT955 with an IOT (data only) SIM with T-mobile operator in The Netherlands gives the same issues.

Using the same setup with a regular KPN provider sim gives no issues.