Ask a question

2721 questions

3398 answers

4842 comments

4135 members

Ask a question
0 votes
36 views
in Networks by
Hi,

I am trying to set up the Modbus Data to Server option on a RUT955. When setting up the "Requests Configuration" in the "Modbus Serial Master" page and testing I get the following error:

"Request sent
No response from slave device, check wiring and configuration"

But if I set the RS485 up as a Mobus Gateway I can poll the same slave device from my server using the same settings so there is no wiring/config issue.

Can you please help? Thanks.

1 Answer

0 votes
ago by
Hello,

Can you send printscreens of your slave requests configuration?
ago by

Thanks for your reply. See attached.

ago by
Can't read values :D

Maybe you can retake prinscreen and also provide information of the device you want to read (model, values, registers and etc.)
ago by

Sorry. Better one attached.

Device is Energy Team, Model NG9. The 2 registers i need are Voltage (Register:7006, 32Bit Float Point) and Active Energy (Register:7500, Unsigned 32 bit Integer)NG9 Modbus Protocol

Thanks.

ago by

Looking at the NG9 Modbus registers, I see that ID in the table is the value of Modbus address. However, in RUT955 you have to enter Modbus register number, which value is one higher (+1) than address, try to use 7007 for Voltage and 7501 for Active Energy. After this you have to get value after pressing "Test".

Just to make sure, after changes first save configuration and then get back to press "Test" button. Since only after saving values are loaded. Also, don't forget to turn off RS485 device in Services -> RS232/RS485 -> RS485, since you have mentioned, that you tested Modbus gateway.

ago by
Thanks Tomas, that's now working. I should have known that!

I now have another issue - The modbus serial master is polling every 60 seconds and the http sender period is also set to 60 seconds but the sender is only sending every 80 seconds or so. This is causing a backlog. I have tried changing the http sender period to 30 seconds but it I am still only receiving data every 80 seconds. Any advice?

Thanks.
ago by
Hello,

Send me a private message with your router troubleshoot and TCPdump (to download TCPdump file, first you have to enable it logging in System -> Administration -> Troubleshoot) files. Before downloading these files let data sender send 2 -3 packages to your server.