Ask a question

2742 questions

3426 answers

4880 comments

4144 members

Ask a question
0 votes
43 views
in Networks by
Hi,

I am trying to set up the Modbus Data to Server option on a RUT955. When setting up the "Requests Configuration" in the "Modbus Serial Master" page and testing I get the following error:

"Request sent
No response from slave device, check wiring and configuration"

But if I set the RS485 up as a Mobus Gateway I can poll the same slave device from my server using the same settings so there is no wiring/config issue.

Can you please help? Thanks.

1 Answer

0 votes
by
Hello,

Can you send printscreens of your slave requests configuration?
by

Thanks for your reply. See attached.

by
Can't read values :D

Maybe you can retake prinscreen and also provide information of the device you want to read (model, values, registers and etc.)
by

Sorry. Better one attached.

Device is Energy Team, Model NG9. The 2 registers i need are Voltage (Register:7006, 32Bit Float Point) and Active Energy (Register:7500, Unsigned 32 bit Integer)NG9 Modbus Protocol

Thanks.

by

Looking at the NG9 Modbus registers, I see that ID in the table is the value of Modbus address. However, in RUT955 you have to enter Modbus register number, which value is one higher (+1) than address, try to use 7007 for Voltage and 7501 for Active Energy. After this you have to get value after pressing "Test".

Just to make sure, after changes first save configuration and then get back to press "Test" button. Since only after saving values are loaded. Also, don't forget to turn off RS485 device in Services -> RS232/RS485 -> RS485, since you have mentioned, that you tested Modbus gateway.

by
Thanks Tomas, that's now working. I should have known that!

I now have another issue - The modbus serial master is polling every 60 seconds and the http sender period is also set to 60 seconds but the sender is only sending every 80 seconds or so. This is causing a backlog. I have tried changing the http sender period to 30 seconds but it I am still only receiving data every 80 seconds. Any advice?

Thanks.
ago by
Hello,

Send me a private message with your router troubleshoot and TCPdump (to download TCPdump file, first you have to enable it logging in System -> Administration -> Troubleshoot) files. Before downloading these files let data sender send 2 -3 packages to your server.
ago by
Thanks Tomas. It was actually a problem on the receiver end.

The issue I have now is when I send the modbus values by http I get 2.34654+e2 instead of 234.654. The + sign is causing an issue with my server collecting the data. If I poll it directly from the router in the Modbus Serial Master page with the Test button I get the correct value, 234.654.
Can I get the http sender to send the data as I see it under test without the scientific notation?
ago by
Hi,

Unfortunately, but no. Data is formatted in this way and there is no configuration for this.