subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,284 views 9 comments

On my RUT955 (HW Rev 1106, FW 00.06.06_WEBUI, factory defaults) the bootloader update to 3.2.5 bricked the device. The only lifesign of the router is a blinking LAN3 LED. Many other users seem to have the same problem. Teltonika has removed the bootloader download in the meantime. 

These are strong signs that the devices were damaged by a faulty bootloader software. Shit happens but please act responsible and offer a solution to get the broken devices back to work. I love these devices and have about 20 of them. 


by anonymous

Yes, unfortunately you're not alone. I had exactly the same problem as described in this thread

I made a RMA request to Teltonika regarding this issue about three days ago but no response...frustrating to say the least.

2 Answers

0 votes
by anonymous


We would like to contact all crowd support users from this thread, regarding sending devices to warranty. However, some messages were sent anonymously, therefore we have cannot initiate private conversation.

If your devices are no longer reachable due to upgrading device's bootloader and you have not been contacted via any private channels yet, please:

  • Make sure that you have Crowd Support Forum account and you are logged in. To create the account, pressed "Login" button in the top right corner of this page and then click "Register".
  • Respond to this thread, or write me a private message
Best answer
by anonymous
Please contact me for sending my RUT955 to warranty regarding the boot loader issue. Thanks!
by anonymous
I have this issue, can you help?
by anonymous
Hi I messaged before, weirdly the device resolved itself but it's happening again but without signs of life other than the blinking LAN3 port. Please can you get in touch I'd like to send the item to be replaced.
by anonymous
Dear all,

I also have the same issues and I run mad to find information online about it... Finally, I am not sure even how, I bumped into this, please help.

I was super happy with my device till when, after I while that I cold not use it (covid restrictions, RU955 was in another place) I turn it on and update the firmware... I was thinking it was the right thing to do but ... it is dead now! I tried everything I cold but even the serial console return a white screen. Can you help me to fix it please.

Let me know anytime.

All the best,

by anonymous


Could you  connect to your device via SSH or CLI and post a screenshot of the output of the following command:

  • hexdump -C /dev/mtd1 

Best regards,

0 votes
by anonymous

Sorry for the delay, we had to investigate the bootloader issue with old HW version at first. Unfortunatelly, devices will have to be shipped back.

Every user that has bricked devices will be contacted on Monday with the details and every bricked router will be repaired for free regardless of whether the warranty is expired or not.
Great - thanks!
by anonymous
I've just started having this issue, can you help please?
by anonymous
Hello i'm french and i'd get this issue two and have lan led blinking faster like normally.

I search a solution about 6 months ago...

i've 2 rut950 out of service due to this firmware update...

But my routers are some occasions not bought by official resellers...

What could i do please?

How can i do?