subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,808 views 14 comments

My company is looking for a LTE router solution for LTE failover connections. I'm currently testing RUTX09 with firmware RUTX_R_00.02.03.1 and have it attached to a Palo Alto PA-220 firewall in my lab. I can't seem to get Bridged Mode to work and can't find any documentation on how it's supposed to be done.

Currently I have one SIM card for MOB1S1A1 (default) interface and I have tested that it works in NAT mode. In Bridged mode I assume that I need to insert the MAC address of the firewall interface (MAC address of PA-220 IF) connected to LAN side of the RUTX09. What I'm not sure of is whether I should have the LAN (default) interface configured with "Bridge interfaces" and whether I should have eth0 and qmimux0 in br-lan. I've tried all possible combinations but the result is always that when I do a DHCP renew on the PA-220 I can see with tcpdump on RUTX09 that DHCP requests are coming in to interface eth0 and br-lan bridge but they don't seem to get passed to qmimux0.

If I could get more information or a sample configuration, I would be very grateful. Alternative if someone could explain how the bridging is done on RutOS (which components used, how DHCP queries are passed/relied), I can probably figure out the rest.

by anonymous

I had bridge mode working just fine in firmware version RUTX_R_00.02.01.1, but can't get it to work in RUTX_R_00.02.03.1 - not sure if we're dealing with the same issue or if you're experiencing something else. If you haven't updated your modem firmware to the latest and greatest version, you might be able to get bridge mode working if you simply downgrade to the previous firmware version.

I've outlined my struggles in this post, if that's of any help. The steps provided in that post worked just fine for enabling bridge mode on RUTX_R_00.02.01.1.

1 Answer

0 votes
Thanks! Downgraded to RUTX_R_00.02.01.1 and now I got it working.

I may have found the problem with the new RUTX_R_00.02.03.1 firmware. It doesn't create a LAN_MOB1S1A1 interface to add to br-lan bridge. Thus the mobile and lan interfaces aren't bridged and therefor no traffic can flow through it.
by anonymous


your logs look fine. I can see that, you are getting IP configuration (Current settings retrieved:).
Proxy arp is enabled too ( = 1)

DHCP settings fine too:

(DHCP, IP range --, lease time 12h

DHCP, static leases only on AA.BB.CC.51, lease time 1h)

I can't see any problems.

by anonymous
Regarding DHCP: I thought enabling bridge mode was supposed to disable DHCP? Seems like it would mess with the router downstream otherwise?
by anonymous
It's not necessary to disable dhcp. You can use routers local network, just traffic to outside will be allowed only from device that has IP from ISP.
by anonymous

With some help from Simonas, we concluded that RUTX in bridge mode together with macOS requires some additional configuration on the client-side to work properly. I don't remember the minimal step-by-step guide to get it working, but that might be something other folks run into...

When trying a factory reset RUTX09 on firmware RUTX_R_00.02.03.1 together with a USG (or UDM Pro) it works just fine - only step needed post factory reset of the RUTX09 was enabling bridge mode. No need to re-order interfaces since there's nothing connected on the WAN side, nor is there a need for a specific MAC address in the bridge mode settings since there's only one device hooked up to the device.

Works for me, moving on!

I had the same problem, upgraded to firmware RUTX_R_00.02.04.1 and it would not connect in bridge mode, could only get it to work when i downgraded to RUTX_R_00.02.01.1. As posted before it didn't create the LAN_MOB1S1A1 connection. There must be a bug in the firmware to cause this. Hopefully its fixed soon.