10926 questions

13028 answers


27365 members

0 votes
241 views 0 comments
By mistake i set Redirect to HTTPS to yes in Access control of RUT955. I have remote access with ssh. Is it possible to set Redirect to HTTPS to no with CLI?

1 Answer

0 votes


First, you will have to navigate to /etc/config folder: 

cd /etc/config

Then edit file uhttpd:

 vi uhttpd

To start editing the file press letter " I " on the keyboard.

Find option called:

option redirect_https '1'

Edit this option to:

option redirect_https '0'

Save it by pressing ESC on your keyboard and writing:


Press enter and you should have "Redirect to HTTPS" disabled.

It can take time for config to reload, but if it doesn't save you can just restart your router and it should be not redirecting to HTTPS anymore.