4221 questions

5218 answers

8039 comments

5224 members

0 votes
186 views 5 comments
by
I have added a static route:
interface = the l2tp vpn
target = 192.168.74.0 (my local network)
netmask = 255.255.255.0
ipv4 gateway = 192.168.124.254 (my mikrotik router:s ip in the vpn connection. I can ping it from rutx11)
metric =1
MTU=1500
Route type = Unicast

I am not able to ping anything on 192.168.74.x and the route does not appear in cli typing "route"
and it is not visible under "status"-Routes-general routes

What am I missing? It does not seem to appear in the routing tables
by
This is supposed to be so simple... tell the RUTX11 where to send and response to any traffic originated 192.168.74.x

That is the mikrotik router end with the transport ip 192.168.124.254

2 Answers

0 votes
by
Turns out if I do the exact same thing with pptp it all works. Must be some kind of bug. I have tried factory reset several times, making less and less changes from original setup and for now thats my solution. Dont use l2tp.

Security on this link is not an issue so pptp will be fine.

/H
Best answer
0 votes
by

Hi, could you please give more information about the interfaces you have now?

  • Both of your L2TP IP addresses of your routers.
  • Both of your LAN IP subnets and routers LAN addresses.
  • Names of L2TP tunnel shown when executing ifconfig command on both sides.
Even a full topology would be helpful.
Thank you.
EB.
by

L2TP: 
Mikrotik = 192.168.124.254
RUTX11 = 192.168.124.12
LAN:
Mikrotik = 192.168.74.254 / 24
RUTX11 = 192.168.3.1/24
ifconfig:
RUTX11= 

l2tp-client_Kla Link encap:Point-to-Point Protocol                                                                                                                                                                                                                                                               
          inet addr:192.168.124.12  P-t-P:192.168.124.254  Mask:255.255.255.255                                                                                                                                                                                                                                  
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1450  Metric:1

by

This setup is saved but not listed if i run rout or check the web gui.

by

In RUTX11 CLI add this route and check if you can ping:

ip route add 192.168.74.0/24 via 192.168.124.254 dev l2tp-client_Kla

by

Ping ok, not traceroute... and not the other way
root@Teltonika-RUTX11:~# ping 192.168.74.73

PING 192.168.74.73 (192.168.74.73): 56 data bytes

64 bytes from 192.168.74.73: seq=1 ttl=63 time=87.193 ms

--- 192.168.74.73 ping statistics ---

2 packets transmitted, 2 packets received, 0% packet loss 

round-trip min/avg/max = 78.431/82.812/87.193 ms

root@Teltonika-RUTX11:~# traceroute 192.168.74.73 

traceroute to 192.168.74.73 (192.168.74.73), 30 hops max, 38 byte packets 

1  *  *  * 

2  10.9.47.81 (10.9.47.81)  22.432 ms  10.9.47.89 (10.9.47.89)  13.617 ms  10.9.47.81 (10.9.47.81)  13.730 ms 

3  10.9.47.21 (10.9.47.21)  13.678 ms  13.620 ms  13.419 ms 

4  10.9.47.26 (10.9.47.26)  13.429 ms  13.666 ms  13.407 ms 

5  *  *  *  

6  *  *  * 

7  *^C

root@Teltonika-RUTX11:~# route 

Kernel IP routing table  

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface 

default         10.208.197.58   0.0.0.0         UG    1      0        0 qmimux0  

10.208.197.56   *               255.255.255.252 U     1      0        0 qmimux0 

192.168.12.0    *               255.255.255.0   U     0      0        0 br-lan 

192.168.124.254 *               255.255.255.255 UH    0      0        0 l2tp-client_Kla