3753 questions

4658 answers


4867 members

0 votes
60 views 5 comments
ago by
I have added a static route:
interface = the l2tp vpn
target = (my local network)
netmask =
ipv4 gateway = (my mikrotik router:s ip in the vpn connection. I can ping it from rutx11)
metric =1
Route type = Unicast

I am not able to ping anything on 192.168.74.x and the route does not appear in cli typing "route"
and it is not visible under "status"-Routes-general routes

What am I missing? It does not seem to appear in the routing tables
ago by
This is supposed to be so simple... tell the RUTX11 where to send and response to any traffic originated 192.168.74.x

That is the mikrotik router end with the transport ip

2 Answers

0 votes
ago by
Turns out if I do the exact same thing with pptp it all works. Must be some kind of bug. I have tried factory reset several times, making less and less changes from original setup and for now thats my solution. Dont use l2tp.

Security on this link is not an issue so pptp will be fine.

Best answer
0 votes
ago by

Hi, could you please give more information about the interfaces you have now?

  • Both of your L2TP IP addresses of your routers.
  • Both of your LAN IP subnets and routers LAN addresses.
  • Names of L2TP tunnel shown when executing ifconfig command on both sides.
Even a full topology would be helpful.
Thank you.
ago by

Mikrotik =
RUTX11 =
Mikrotik = / 24
RUTX11 =

l2tp-client_Kla Link encap:Point-to-Point Protocol                                                                                                                                                                                                                                                               
          inet addr:  P-t-P:  Mask:                                                                                                                                                                                                                                  

ago by

This setup is saved but not listed if i run rout or check the web gui.

ago by

In RUTX11 CLI add this route and check if you can ping:

ip route add via dev l2tp-client_Kla

ago by

Ping ok, not traceroute... and not the other way
root@Teltonika-RUTX11:~# ping

PING ( 56 data bytes

64 bytes from seq=1 ttl=63 time=87.193 ms

--- ping statistics ---

2 packets transmitted, 2 packets received, 0% packet loss 

round-trip min/avg/max = 78.431/82.812/87.193 ms

root@Teltonika-RUTX11:~# traceroute 

traceroute to (, 30 hops max, 38 byte packets 

1  *  *  * 

2 (  22.432 ms (  13.617 ms (  13.730 ms 

3 (  13.678 ms  13.620 ms  13.419 ms 

4 (  13.429 ms  13.666 ms  13.407 ms 

5  *  *  *  

6  *  *  * 

7  *^C

root@Teltonika-RUTX11:~# route 

Kernel IP routing table  

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface 

default         UG    1      0        0 qmimux0   *      U     1      0        0 qmimux0    *        U     0      0        0 br-lan *      UH    0      0        0 l2tp-client_Kla