FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
611 views 3 comments
by

I'm having a headache of an afternoon and hopefully someone can point me in the right direction.

Following on from my previous question: https://community.teltonika-networks.com/20889/rut850-snmp-optional

Though I commented that I had got the SNMP installed and working I had foolishly tested it on an RUT955 as when I got the answer my RUT850 was unavailable.

I've tried to copy what I did on the RUT955 with the RUT850 but I'm having a little trouble. First issue, there doesn't seem to be a package manager option on the web GUI, and all RUTs I have on my VPN do not have access to the internet themselves so I have to do it via SSH and SCP the file over.

Second issue I have is that on the wiki (https://wiki.teltonika-networks.com/view/RUT_Routers) every router link then has an issue for Package Downloads except the 850. I can't seem to find any packages any where on the internet for the 850...

So I copied over the 9xx SNMP package and attempted to install that. It complains that the 850 doesn't have enough storage to install the package. I check the storage and it all seems to be in /tmp/.

I looked up how I could change the filesystem when installing:

opkg -d destination_name install somepackage

and then opkg.conf contain three destinations:

dest root /
dest ram /tmp
dest mnt /mnt

so I attempted the below:

Now it's saying I'm missing dependencies but I can't seem to find a way to install them either.

My head hurts and I'm probably missing something obvious, could someone please point me in the right direction?

Thanks,

Daniel

by anonymous
Hi Daniel,

to confirm your observation: I just experienced the same issue on a similar device: RUT955. However I was using the LUCI GUI, menue Systrem > Package Manager. First I installed two packages: SNMP tools and USB tools. Then I was creating 2 additional user profiles. After that the Package Manager reports "no space available" for SNMP tools and USB tools (which have been successfully installed before).

Btw.: Using the LUCI menue: System > Extend Memory I added a 1 GB partition of a USB memory stick connected to my router and after that the Package Manger does not report "no space available" any more and allows me to install additional packages.

BR
Aleko

1 Answer

0 votes
by anonymous
Hello, Daniel,

I forwarded your issue to the RnD department. I will let you know as soon as I have the news.
by
Hi Marius,

Were the RnD department able to find a solution for this? I've temporarily switched to using JSON-RPC which is giving me some of the information I want but I would much prefer SNMP.

Thanks,

Daniel
by anonymous
Hello,

RnD department found the issue and fixed it. So far we only have test firmware. I could send you a test firmware in a private message. Register in our forum and write me a private message, I will then send you.