subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,373 views 2 comments

Connecting computer to LAN-port on RUT-240 I get this when using 

And connecting to the same via wifi I get this:

Here's what the signal strengths are for the wifi-connection 

2 Answers

0 votes
by anonymous


RUT240 WiFi operates in 2.4Ghz frequency and a lot of devices use 2.4Ghz wavelength. While you may not have many of these devices in your home, if you live in apartment surrounded by other people, that 2.4Ghz band is likely congested with number of devices.

You could try to switch your WiFi mode between Auto, 802.11b, 802.11g, 802.11g+n and check if your connection improves (Go to Network > Wireless > Edit > Advanced Settings).

Also there could be issue with your PC wireless adapter.

  • Go to Computer Properties and then go to Device Manager;
  • In Device Manager go to Network Adapter and expand it;
  • Now find your WiFi driver. Something like Realtek RTL8723BE 802.11 b/g/n Wi-Fi Adapter;
  • Right click it and go to Properties. Then go to advanced tab.
  • In this Menu go to Wireless Mode. On the right side you will see the Value field;
  • Change the value to IEEE 802.11 from the dropdown Menu. and click apply and save. Wifi router will restart itself.

Hopefully the problem will be solved. Let me know if problem persists.



I was at a location with no other wifi-devices present, so congestion should not be the issue here. Also, I use a Mac, wifi mode should be automatically selected. I also experimented with setting different modes on the RUT240.

One other note, when I got back home plugged in my cable modem to the WAN-port of the RUT240. Connection speed from the Internet to cable modem is 100Mbit/s. I got about 10 Mbit/s on the wifi. About 10 times faster than on 4G.
by anonymous

There could be many factors that may affect your WiFi performance:

  • Check if your WiFi antennas are attached firmly (try to remove them and attach again)
  • Try to test speed with other devices (not only MAC);
  • Perform not only speedtest but also iperf;
  • If there is possibility, try another power adapter for your router;
  • Upgrade your device to the latest firmware;
  • Reset router to factory default configuration;
0 votes
by anonymous

I had the same issue. Go to WIRELESS- GLOBAL SETTING and General Setup. Then check if "mode" is set to legacy. If so, change this to "N". That did the trick for me. Download and upload speed is now consistent, and in the 15-20 mbs range.