4781 questions

5854 answers

9372 comments

5704 members

0 votes
149 views 3 comments
by

RUT 240 Wired WAN interface name changed to "-" after added VLAN and it didn't show on the load balancing interface drop down list.

Anyone have an idea to fix it?

1 Answer

0 votes
by
Hi,

Could you please explain in more detail / step by step how did you configure your device before this happened?

EB.
by
Hi EB,

I use the CLI and edit below line in /etc/config/network

config interface 'wan'

option enabled '1'

option ifname 'eth1' changed to 'eth1.100' to set the WAN with VLAN 100 for NBN.

After changed to eth1.100, the interface name for the Wired WAN become "-" and didn't show on the load balance list.

EGG
by
I've reported your issue to RnD, I will get back to you once I have any useful information.

EB.
by

Hi,

As you are changing the config - WebUI will not like it and nothing will show up in WAN placeholders.

But there is a workaround with Load Balancing.

You should head over to /etc/config/

and edit the network config file so you would have two Wired WAN interfaces. One that you have now and another one identical but with a VLAN option added.

This way you will avoid Load Balancing drop-down menu breaking and you should be able to select your modified WAN interface.

To your newly created WAN interface give this option:

        option ifname 'eth1.100'

EB.