FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,042 views 11 comments
by anonymous

I have 10 TRB145 units which so far seem to have ver1.04.

Every time I try to upload TRB1451_R_00.02.03.2_LEGACY.bin it fails to after uploading the file via the web browser.

I can upload ver1.06 without a problem and haven't had any problems with the TRB140 that I have updated last month.

So the first two unit I was able to copy the firmware onto the device and then ssh into run /usr/sbin/sysup.  Then was able to use the web browser to update it to the latest ver2.05.1

But the 3 unit doesn't seem to boot up and when I hold the reset for 5 seconds it comes up as a Kedacom USB/ Android bootloader device?

root@TRB145:~# /usr/sbin/sysup -v /tmp/firmware.bin

[Severity ] Message

[Info     ] Flashing kernel image

[Info     ] kernel image flashed succesfully

[Info     ] Flashing rootfs image

[Warning  ] Bad erase block no 39

[Info     ] rootfs image flashed succesfully

[Info     ] Flashing modem image

[Info     ] modem image flashed succesfully

[Info     ] All images flashed succesfully

[Info     ] Changing the boot configuration from a to b

[Info     ] Rebooting...

by anonymous

[Debug    ] modem file name: trb1451-modem.ubi

[Debug    ] modem sha1: e2b0d25b1a6822c9e1a61bf9ee1295fe0efb98ce

[Debug    ] modem size: 41943040

[Debug    ] bootloader image does not exist

[Error    ] SHA1 checksum missmatch for modem

[Error    ] modem checksum validation failed

[Error    ] Failed to validate modem image

[Crit     ] Upgrade package validation failed

Also have re-downloaded TRB1451_R_00.02.03.2_LEGACY.bin no difference 

Calculated the SHA1 to be 3cde6af4c7d2c766c25e5fb77bd9d840339bff16, which is the same hash for trb1411-modem.ubi

1 Answer

0 votes
by anonymous
Hello,

Regarding this issue of yours i am currently waiting response from our HQ for the solution of the issue you are having.

Thank you and have a nice day!

Regards,
Jerome
Best answer
by anonymous
Hello,

Here is a solution to the issue you are having kindly follow the steps provided below:

1.Turn off/unplug TRB14x;
2.Press and hold reset button, at the same time plug the power cable and keep holding reset button for about 5 seconds (mobile signal LED's should start blinking);
3.Download and install adb from this link: https://forum.xda-developers.com/showthread.php?t=2588979
4.Use cd command to navigate to the place where you saved the tlt-rootfs-trb1451 file (Example: cd C:\Users\ma.ju\AppData\Local\Temp);
5.Then use this command: fastboot flash rootfs_a tlt-rootfs-trb1451.ubi;
6. When it completes the process use this command; fastboot flash rootfs_b tlt-rootfs-trb1451.ubi ;
7.Then use this command: fastboot flash boot_a tlt-boot-trb1451.img ;
8. When it completes the process use this command; fastboot flash boot_b tlt-boot-trb1451.img;
9. When it is done unplug and plug your device again, it should boot up as normal

UBI Files Link: https://we.tl/t-NXSALBKSoD

Hope it helps

Regards,
Jerome
by anonymous

Thanks Jerome that worked, the trb145 is now unbricked.

So what about the TRB1451_R_00.02.03.2_LEGACY.bin having what I assume is an incorrect hash for trb1451-modem.ubi?

Cheers, Dennis

by anonymous

Hello, 

You're most welcome the legacy bin is used when the device is having a firmware of TRB145X_R_00.01.06.1 or Older. 
But if you successfully recovered the trb device you can update it to the latest firmware :) without using the legacy firmware.  

Hope it helps,

Regards,
Jerome 

by anonymous

Hi,

I have another 6 TRB145 (AU & NZ ver) to upgrade to the latest v2.05.1, but the first step is to upgrade the units to TRB1451_R_00.02.03.2_LEGACY.bin, but via the web browser it fails, after copying this bin to the unit run sysup I see the following below, but to progress I run the same cmd but with hte flag to ignore the checksum

[Debug    ] modem file name: trb1451-modem.ubi

[Debug    ] modem sha1: e2b0d25b1a6822c9e1a61bf9ee1295fe0efb98ce

[Debug    ] modem size: 41943040

[Debug    ] bootloader image does not exist

[Error    ] SHA1 checksum missmatch for modem

[Error    ] modem checksum validation failed

[Error    ] Failed to validate modem image

[Crit     ] Upgrade package validation failed

by anonymous
Hello,

Attaching ubi and img files.

https://we.tl/t-2SOHjm3GY8

Hope it helps

Regards,

Jerome
by anonymous
I have the same problem with trb145, can I ask for an active link to ubi.
by anonymous
Hi
Please assist me with the same Issue. This is rather urgent and want to avaid another RMI if possible.
by anonymous
Hello,

For this thread to be updated you can check this link: https://mega.nz/folder/KqJUSTqa#AVztqX8H8MBpu0TVIN43uQ

Regards,

Jerome
by anonymous

Hi, I have got it right to re-load the firmware but I now can't seem to be able to get into the WebUI?
Looks like the device is now booting correctly but when I go to the WebUI it gives me the following error:

Bad Gateway The process did not produce any response.

I also Have a TRB 141 not 145, But I do have the correct files now I believe

by anonymous
Hello,

I have a similar issue with my trb145. Could you maybe provide an active link to the images?