7953 questions

9404 answers

15104 comments

12982 members

0 votes
248 views 1 comments
by
I have a router with address 192.168.1.1 with internet access, dhcp disabled

My teltonika RUT240 is connected to this router via lan port (IP: 192.168.1.2) and I have enabled dhcp. I need to connect to internet with my smartphone using wi-fi of my teltonika rut240 but when it assign me the IP, the gateway address assigned is 192.168.1.2 and not 192.168.1.1 so that I don't have internet access. How can I do to automatically assign to the smartphone gateway address 192.168.1.1? Thank you

1 Answer

+1 vote
by

Hello,

Could you tell me why is it important that your RUT240 and another router would be connected using LAN to LAN instead of LAN to WAN?

But despite that you can change Gateway that DHCP server gives out (I've just tested it and setup worked without problems)

Leaving yours setup as it is you need to go to RUT240 WebUI Network > LAN > DHCP Server > Advanced settings tab and add 2 DHCP Options:

  • 3,192.168.1.1this describes alternative Gateway
  • 6,192.168.1.1this describes alternative DNS server you MUST add this otherwise you will have no connectivity, since RUT240 itself does not have WAN it will not have functioning DNS server either.

Here how it looks in settings:

This should solve yours issue.

Best regards,
VidasKac.

Best answer
by
I didn't use wan because the modem is connected to a switch with other pc and instruments and my rut240 is connected to this switch. If I use wan I create two different lan (one before rut240 and another one after rut240) that can't communicate between them (I think...)

But despite that, your solution works great. Thank you. Is there a list of DHCP options available? I can't find them on teltonika-wiki. Thank you again