5277 questions

6429 answers

10373 comments

6440 members

0 votes
197 views 13 comments
by

Hi I received a new RUTX11 yesterday hoping it would be the perfect solution to my broadband issues. The device was supposed to replace a Netgear M2 mobile router that has been working perfectly in bridge mode when connected to my Draytek Vigor 2862. This setup works flawlessly. 

However, despite spending a whole day and most of the night yesterday and even updating the RUTX11's firmware to this: RUTX_R_00.02.05.2_WEBUI it still does not work in bridge or passthrough modes. 

Furthermore the documentation states "Important: using Passthrough mode will disable most of the router’s other capabilities."  and "Important: using Bridge mode will disable most of the router’s other capabilities" which is not true, nothing seems to get disabled, unless the UI does not reflect the devices true status. 

Unfortunatly, I don't have any more time to spend on this now and will need to either purchase another Netgear M2 or Draytek Vigor2620, so this will be returned to Amazon unless there's an obvious solution to this problem today. 

by
There are couple of bugs, but I was able to connect it via bridge mode. First of all, check if you're getting internet connection when using NAT.

If that works, change MOBILE INTERFACE connection from NAT to bridge and write MAC address of your router's WAN port into that field.

Next, in LAN INTERFACE settings:

Protocol: Static

IP Address: 192.168.1.1

IPv4 Netmask: 255.255.255.0

Enable DHCP: Enable

Start: 1

Limit: 1

Lease 12h

You can use different IP, but last octet should be same for start and end of dhcp in order not to work for local addresses. You can also use different Lease time. In this case, your router behind RUTX device won't get any private IP from RUTX, only IP (might be private or public) from ISP. Also, it does make a change to use it in bridge mode as I'm getting similiar or same download speed, but 2x more upload speed - from 20mbit/s (NAT) to 40mbit/s (bridge).

1 Answer

0 votes
by
Hi,

Sorry that you have troubles with our device. Unfortunately, I couldn't reproduce your issue and successfully got SIM private IP leased through bridge mode.

It takes time to get a lease, are you sure you waited long enough to get the IP? Also, make sure you don't have manual IP set on your network adapter configuration.

Settings that are mentioned to be disabled in bridge/passthrough mode do not get disabled fully, because you just skip routers gateway and do not go through any of the configurations while in bridge.

EB.
by
OK - So I just followed these steps.

Everything works fine in NAT mode and I can connect to the internet. However in bridge mode no connection and no data is ever sent.
by
Any update on this - if it’s not resolvable I’ll have to return it tomorrow. This was meant to be an easy solution, but so far its not been easy. As I mentioned earlier my cheaper NetGear and Draytek work out of the box.

Carl
by
Sorry to hear that, but these steps were easy as they sound. Please check your internal configurations on Draytek. Maybe you're not connecting it right or have a wrong MAC typed in.

I've tried it now on numerous RUTX devices and can't reproduce your issue.

EB.
by
Well I’m not sure where to look on my Router because it works perfectly with my Netgear M2 and other devices and I don’t need even need to provide a MAC address. The MAC address I used  is exactly as shown in the screen shot above.

Carl
by
So it appears the problem here is actually the Mac address. Basicly, its not needed and actually stops the Draytek router acquiring an IP address. If you leave the MAC address field empty it work.