FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,209 views 13 comments
by anonymous

Hi I received a new RUTX11 yesterday hoping it would be the perfect solution to my broadband issues. The device was supposed to replace a Netgear M2 mobile router that has been working perfectly in bridge mode when connected to my Draytek Vigor 2862. This setup works flawlessly. 

However, despite spending a whole day and most of the night yesterday and even updating the RUTX11's firmware to this: RUTX_R_00.02.05.2_WEBUI it still does not work in bridge or passthrough modes. 

Furthermore the documentation states "Important: using Passthrough mode will disable most of the router’s other capabilities."  and "Important: using Bridge mode will disable most of the router’s other capabilities" which is not true, nothing seems to get disabled, unless the UI does not reflect the devices true status. 

Unfortunatly, I don't have any more time to spend on this now and will need to either purchase another Netgear M2 or Draytek Vigor2620, so this will be returned to Amazon unless there's an obvious solution to this problem today. 

by anonymous
There are couple of bugs, but I was able to connect it via bridge mode. First of all, check if you're getting internet connection when using NAT.

If that works, change MOBILE INTERFACE connection from NAT to bridge and write MAC address of your router's WAN port into that field.

Next, in LAN INTERFACE settings:

Protocol: Static

IP Address: 192.168.1.1

IPv4 Netmask: 255.255.255.0

Enable DHCP: Enable

Start: 1

Limit: 1

Lease 12h

You can use different IP, but last octet should be same for start and end of dhcp in order not to work for local addresses. You can also use different Lease time. In this case, your router behind RUTX device won't get any private IP from RUTX, only IP (might be private or public) from ISP. Also, it does make a change to use it in bridge mode as I'm getting similiar or same download speed, but 2x more upload speed - from 20mbit/s (NAT) to 40mbit/s (bridge).

1 Answer

0 votes
by anonymous
Hi,

Sorry that you have troubles with our device. Unfortunately, I couldn't reproduce your issue and successfully got SIM private IP leased through bridge mode.

It takes time to get a lease, are you sure you waited long enough to get the IP? Also, make sure you don't have manual IP set on your network adapter configuration.

Settings that are mentioned to be disabled in bridge/passthrough mode do not get disabled fully, because you just skip routers gateway and do not go through any of the configurations while in bridge.

EB.
by anonymous
Thanks,

Please can you share your exact configuration and I will try again.

Carl
by anonymous
It was done on full default factory configuration. Reset your router and try again. As I said, make sure your network adapter settings on your computer are set to automatic so it could be possible to lease you an address of the SIM. Next thing you might want to check - is the MAC that you've entered is correct.

EB.
by anonymous
Hmm - OK, I'm confused. Can you provide a list of the exact steps you took from the factory settings, assuming step 1. is to connect a laptop (with DHCP configure for its ethernet connection) to the RUTX11's lan port and open a browser to 192.168.1.1.

CArl
by anonymous
Yes, after you're in WebUI you head to your Interfaces and select mobile interface. In it select Bridge mode and under Auto APN write your MAC address of the network adapter you're connecting LAN cable to.

EB.
by anonymous
OK - i will try this. Should I also disable DHCP on the RUTX11's LAN port since main router is already running a DHCP service ?

Carl
by anonymous
It doesn't matter as you're trying to give out Bridge mode from the modem, not the IP that is coming from other router.

EB.
by anonymous

Ok so I reset my RUTX11 to factory, entered the mac address (14-49-BC-0B-57-42) as per the WAN (WAN2) address that the RUTX is connected to on my Draytek router. However, I still don't get a connection to establish. 

Is there anything else I'm missing ? 

by anonymous
OK - So I just followed these steps.

Everything works fine in NAT mode and I can connect to the internet. However in bridge mode no connection and no data is ever sent.
by anonymous
Any update on this - if it’s not resolvable I’ll have to return it tomorrow. This was meant to be an easy solution, but so far its not been easy. As I mentioned earlier my cheaper NetGear and Draytek work out of the box.

Carl
by anonymous
Sorry to hear that, but these steps were easy as they sound. Please check your internal configurations on Draytek. Maybe you're not connecting it right or have a wrong MAC typed in.

I've tried it now on numerous RUTX devices and can't reproduce your issue.

EB.
by anonymous
Well I’m not sure where to look on my Router because it works perfectly with my Netgear M2 and other devices and I don’t need even need to provide a MAC address. The MAC address I used  is exactly as shown in the screen shot above.

Carl
by anonymous
So it appears the problem here is actually the Mac address. Basicly, its not needed and actually stops the Draytek router acquiring an IP address. If you leave the MAC address field empty it work.