subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
617 views 11 comments

Hello, I have a RUT230 without phisical access.

I have upgraded the firmware through local web interface (a RaspPi with remote access on the connection of the RUT230), with tick on "keep all settings". new firmware is RUT2XX_R_00.01.13.2

Now the connection does not reestablish, even after a power supply cycle of the whole system.

The SMS utilities are working. With "status" the reply is

Router name - RUT230; WAN IP - ; Data Connection state - disconnected; 

Connection type - HSDPA+HSUPA; Signal Strength - -57 dBm; New FW available - No;

Is there a way to re-connect the data connection with sms utilities?

Thank you,


1 Answer

0 votes
by anonymous


It could be that somehow APN might have changed or isn't parsed as it should.

What I would suggest is reset the device without keeping the settings with SMS utility text restore.

This way you will put your device into reset procedure and once it's done we can be sure there's nothing else that could be wrong with the device, so only APN set-up is left.

Then what we should do is send uci commands through sms utility. Please let me know how it goes.

<adminPassword> uci set simcard.sim1.auto_apn='0'

<adminPassword> uci set simcard.sim1.force_apn='-1'

<adminPassword> uci set simcard.sim1.apn='bangapro'

<adminPassword> uci commit

<adminPassword> luci-reload


Best answer
by anonymous

It's okay that uci commit and luci-reload didn't respond to you, it's normal. And if you had luck without APN, just with AUTO, you can try auto setting then. Just to make sure everything is clean try restoring again, and then just leave it to load normally.

SMS utility status should give you the state of your mobile connection.

No luck with clean restore and leave it with auto-apn=1.

I checked "uci show simcard" for two RUT230 that are working and there are these additional settings:

simcard.ppp.demand=10; simcard.sim1.method=nat;simcard.sim1.force_apn=137;simcard.sim1.mtu=1500

I added them, but still no luck.

maybe is not set to go to mobile? can we set to connect straight away with mobile instead of first test wired WAN, if it is so by default?

I did an additional reboot  and it seem it WORKED!!!

I will go to change local ip and check everything is good, but for now seem ok (SMS status -> connected)

The setting that made the difference seem to be "force_apn=137", what does it mean for information?

Thank you very much and congratulation, the SMS utility is a robust and very powerful tool!


by anonymous
Thank you for your appraisal :)

force_apn=137 means that function selects 137th APN from the database.

And glad that you sorted out the issue yourself!


I confirm that have now the raspberry online! You helped a lot pointing in the right direction, much appreciated!



i was finally issuing the commands with the value without '  '  

I dont know if it makes any difference, but I notice on the second router respnses were


instead of


all good from my side. Best regards!