FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12682 questions

15066 answers

24137 comments

47099 members

0 votes
261 views 5 comments
by

Hi, 

I am trying to configure RUTX as my core network device (for transportation system). I have the following network interfaces:

  • LAN1 : Wired, Static, DHCP on, 192.168.7.0/24, VLAN 1
  • LAN2, LAN3: Wired, Static, on, 192.168.6.0/24, VLAN 6

I also need 2 wifi SSID that I want on other subnets so I created 2 more vlans and 2 network interfaces with physical interface set to the wifi network and the Switch vlan.

So far this is working.

I need to have static DNS entries for a local domain so I activated Network > DNS and uploaded a hosts file.

DNS is working fine when I connect my computer with wifi or wired.

I need a hotspot as well. So I created a hotspot on a wifi network not binded to a network.

Clients on the hotspot will need to access a server in the LAN1 network.

But this is not working, I cannot ping the server in my LAN1 network when connected to the hotspot. I can ping addresses on internet though.

How can I do that as the hostpot network does not seem to be in a firewall zone ?

Is there a way to allow traffic from hotspot to a firewall zone or to another network ?

thank you,

Brice

1 Answer

0 votes
by
Hi,

You can create zones and edit traffic between them.

https://wiki.teltonika-networks.com/view/RUTX11_Firewall#Zones

So if you have a new LAN interface created - just drop it in the covered networks, most importantly allow to receive from the WAN zone and allow forwarding to the WAN zone so the zone interface has internet.

EB.
Best answer
by

Thank you for your answer but I am still confused.

In the Hotspot config, you can only add interfaces. The wireless interface with the chosen SSID is set and I can add other interfaces. The wireless interface has no network configured because Hotspot config asks that network is to be removed from the interface config.

BUT in the firewall zone config, I can only add Networks in the Covered networks drop-down.

So how can I add the hotspot (in fact, the wireless interface I guess) in a firewall zone ?

I'm not even sure that my question is correct as I am really confused.

by
Hotspot has it's own LAN interface, so in dropdown menu you're adding not the wireless selection, but the interface itself, so let's say LAN for Wireless is named "lan2", so you need to find it in dropdown menu - if it's created of course.

How to add an interface could be found here: https://wiki.teltonika-networks.com/view/RUTX11_Interfaces

EB.
by

My hotspot interface does not appear in the "Covered Networks" in the firewall config page nor does it shows in the "Network Interfaces" config page. I think it does not appear there because no network is selected in the wireless interface config. As I said, when configuring a wireless as a hotspot, I am asked to remove the network configured in the wireless interface.

routing table is ok and hotsopt ip addresses are binded to a tun0 interface in netstat -rn result.

Here a a couple of pictures of my config.

thank you

by

Hi,

First of all, add an interface:

Give it static protocol, IPV4 address 192.168.2.254, Netmask 255.255.255.0 and CUSTOM Physical interface:

And save it.

Go to Wireless and create new access point with chosen network as custom interface.

Then go to Services > Hotspot and create a hotspot, you should now see custom interface selection in dropdown appeared. 

Remember to create a local user, as it will not let you enable the hotspot without it.

And it should be done, now you can go to firewall zones and you will see that you can now add a Zone that has HOTSPOT in its covered networks.

EB.

by
Thank you, it does work with that last procedure, even though I still had the "Please remove Networks on wifi interface" when I create the hotspot. I ignored it and I was able to create a new zone with the hotspot in it and then allow traffic from the hotspot to a subnet.

thank you again, have a nice day.

Brice